summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-05-23 01:41:19 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-05-23 01:46:50 +0200
commit53facdb0ddc73fd3047c99fc7bf90d990b15400d (patch)
tree0133cc8a97c4c887accd77a9b6a03ccef52a8380 /app-emacs/esup/esup-0.7.1_p20220203.ebuild
parentnet-vpn/networkmanager-strongswan: add 1.6.0 (diff)
downloadgentoo-53facdb0ddc73fd3047c99fc7bf90d990b15400d.tar.gz
gentoo-53facdb0ddc73fd3047c99fc7bf90d990b15400d.tar.bz2
gentoo-53facdb0ddc73fd3047c99fc7bf90d990b15400d.zip
app-emacs/esup: new package; add version 0.7.1_p20220203
2022.02.03 snapshot Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/esup/esup-0.7.1_p20220203.ebuild')
-rw-r--r--app-emacs/esup/esup-0.7.1_p20220203.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/esup/esup-0.7.1_p20220203.ebuild b/app-emacs/esup/esup-0.7.1_p20220203.ebuild
new file mode 100644
index 000000000000..e3d78933734e
--- /dev/null
+++ b/app-emacs/esup/esup-0.7.1_p20220203.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=4b49c8d599d4cc0fbf994e9e54a9c78e5ab62a5f
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="Benchmark Emacs Startup time without ever leaving it"
+HOMEPAGE="https://github.com/jschaf/esup/"
+SRC_URI="https://github.com/jschaf/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+LICENSE="GPL-3+"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-emacs/s"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-emacs/buttercup
+ app-emacs/dash
+ app-emacs/noflet
+ app-emacs/undercover
+ )
+"
+
+DOCS=( README.md esup-screenshot.png )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ buttercup -L . -L test --traceback full test || die
+}