summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-19 13:07:42 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-19 14:32:47 +0200
commitc7aac162359c3da7bea4eb29a9b8749fb7897fa2 (patch)
tree2895cdf1cbb645a0dcb8d3c417891ba8ad78e67b /app-emacs/git-modes
parentapp-emacs/hl-todo: bump to 3.7.0 (diff)
downloadgentoo-c7aac162359c3da7bea4eb29a9b8749fb7897fa2.tar.gz
gentoo-c7aac162359c3da7bea4eb29a9b8749fb7897fa2.tar.bz2
gentoo-c7aac162359c3da7bea4eb29a9b8749fb7897fa2.zip
app-emacs/git-modes: bump to 1.4.3
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/git-modes')
-rw-r--r--app-emacs/git-modes/Manifest1
-rw-r--r--app-emacs/git-modes/git-modes-1.4.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-emacs/git-modes/Manifest b/app-emacs/git-modes/Manifest
index 709329945e85..d973fddac105 100644
--- a/app-emacs/git-modes/Manifest
+++ b/app-emacs/git-modes/Manifest
@@ -1 +1,2 @@
DIST git-modes-1.4.2.tar.gz 18444 BLAKE2B ecb8894b41ba9f7744a4ceceedea339fca9993bf3b3335c93fd408ad05a7136266ea84cf28891684e0932bf8f1b997f9cb32c4ca7b4f44f735e6c45885f8f012 SHA512 b968b6bab869ad7d8b7232d2a97ab903c30c6fdf8fe0705633f0a7010900d5224f6ea2174708b4ef816241f2a6527bd7eb4f891c2072aee58aea1a153a825d9f
+DIST git-modes-1.4.3.tar.gz 18487 BLAKE2B 2df138576b6eeb628e88bf6f7649f42897d852f89d7d9ab0febc26db0f5c71cc0412ddb511f93b7ce32e444f085747e8f66eabeba5a0182bbe2ff99be3b4b6ed SHA512 0f96e3259ef9c17249f0960c8495043e8b0e2769cdf3b0572e72f83fdecd469403561a4c2666323d0f8d8a3059b8785443662e260881699e0b93e76b3a9e0474
diff --git a/app-emacs/git-modes/git-modes-1.4.3.ebuild b/app-emacs/git-modes/git-modes-1.4.3.ebuild
new file mode 100644
index 000000000000..2a0e06023a16
--- /dev/null
+++ b/app-emacs/git-modes/git-modes-1.4.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs major modes for editing Git configuration files"
+HOMEPAGE="https://github.com/magit/git-modes/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-29.1.4.5
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+
+ elisp-make-autoload-file
+}