summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/planner
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/planner')
-rw-r--r--app-emacs/planner/Manifest1
-rw-r--r--app-emacs/planner/files/80planner-gentoo.el4
-rw-r--r--app-emacs/planner/metadata.xml11
-rw-r--r--app-emacs/planner/planner-3.42.ebuild30
4 files changed, 46 insertions, 0 deletions
diff --git a/app-emacs/planner/Manifest b/app-emacs/planner/Manifest
new file mode 100644
index 000000000000..3aaa1e6132e0
--- /dev/null
+++ b/app-emacs/planner/Manifest
@@ -0,0 +1 @@
+DIST planner-3.42.tar.gz 412086 SHA256 4dc66bf7103ad9dce21e34c40530b040a9718e4b61c16870b3a0f43e1e387129 SHA512 6c0674a1b780005c37850f25ec8b20c72b3d34b6f4e8ad463392e887e498807567af41c0c6ef0f4141230e2d3bf8c702acebae869efc37f72b1e984519c23b3e WHIRLPOOL bcf5ddfca6aa1705108e69a6c973988b0f708ec279fee09d192932861743b28b441da1a198487abe01c1d7a7a6f4b83f29c61179ca096431613c62bd34379979
diff --git a/app-emacs/planner/files/80planner-gentoo.el b/app-emacs/planner/files/80planner-gentoo.el
new file mode 100644
index 000000000000..b7583c2298dc
--- /dev/null
+++ b/app-emacs/planner/files/80planner-gentoo.el
@@ -0,0 +1,4 @@
+(add-to-list 'load-path "@SITELISP@")
+(require 'planner-autoloads)
+(setq remember-handler-functions '(remember-planner-append))
+(defvaralias 'remember-annotation-functions 'planner-annotation-functions)
diff --git a/app-emacs/planner/metadata.xml b/app-emacs/planner/metadata.xml
new file mode 100644
index 000000000000..27000b3f07e8
--- /dev/null
+++ b/app-emacs/planner/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<longdescription>
+Planner is a personal information manager (PIM) for Emacs. You can use
+it to manage your tasks, schedules, notes and anything else you want
+to store in a free-text richly-hyperlinked personal information
+manager integrated into Emacs.
+</longdescription>
+</pkgmetadata>
diff --git a/app-emacs/planner/planner-3.42.ebuild b/app-emacs/planner/planner-3.42.ebuild
new file mode 100644
index 000000000000..d493f914d8a2
--- /dev/null
+++ b/app-emacs/planner/planner-3.42.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit elisp
+
+DESCRIPTION="Maintain a local Wiki using Emacs-friendly markup"
+HOMEPAGE="http://www.emacswiki.org/emacs/PlannerMode"
+SRC_URI="http://download.gna.org/planner-el/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+RESTRICT="test"
+
+DEPEND=">=app-emacs/muse-3.02.6a
+ app-emacs/bbdb
+ app-emacs/emacs-w3m"
+RDEPEND="${DEPEND}"
+PDEPEND="app-emacs/remember"
+
+SITEFILE="80${PN}-gentoo.el"
+ELISP_TEXINFO="planner-el.texi"
+DOCS="AUTHORS COMMENTARY ChangeLog* NEWS README"
+
+src_compile() {
+ default
+}