summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-23 11:31:39 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-23 12:00:07 +0200
commit0b0399982f7bd7ebe435430ef3ba7346111c7934 (patch)
tree66c2be0bfa98555cfb3c119d1b82a4368ca022cd /app-emacs
parentapp-shells/pwsh: remove libSystem.IO.Ports.Native.so on musl (diff)
downloadgentoo-0b0399982f7bd7ebe435430ef3ba7346111c7934.tar.gz
gentoo-0b0399982f7bd7ebe435430ef3ba7346111c7934.tar.bz2
gentoo-0b0399982f7bd7ebe435430ef3ba7346111c7934.zip
app-emacs/company-mode: bump to 1.0.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/company-mode/Manifest1
-rw-r--r--app-emacs/company-mode/company-mode-1.0.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-emacs/company-mode/Manifest b/app-emacs/company-mode/Manifest
index f10eb464d22d..d8f2eb808954 100644
--- a/app-emacs/company-mode/Manifest
+++ b/app-emacs/company-mode/Manifest
@@ -1 +1,2 @@
DIST company-mode-0.10.2.tar.gz 2199965 BLAKE2B f5c931fd128543780a3f61f7f25bc0ac58bdc2e974390482374728b9a6059f35562cc2a201484cb3670bdc6dec63eb423b0c7714605df6457da0fa54008a5a4a SHA512 343ddc7cdeb1b6705a4a2a44979f3940034b32c8725eda2cc29673669737dc8d96d266bd2d44755901665706d0b34abc9e3665e24016f55c1646219029796ade
+DIST company-mode-1.0.2.tar.gz 2208441 BLAKE2B 344f2375baf7397f16d7b5c93f31468ff33242f1730e8654e79a9f18201a59bd0187a0479e2720f5cd122f52e232e0486915ad6a4a3852f9003a9c9eee5ad6b1 SHA512 232902ef1d03a57dd06745ae641e7646a81e96d998aa39752a04204fc767e45837bd9dc48b9a534682180cb51b5229e177174d6eb373f4a9e617d92cc45f508b
diff --git a/app-emacs/company-mode/company-mode-1.0.2.ebuild b/app-emacs/company-mode/company-mode-1.0.2.ebuild
new file mode 100644
index 000000000000..c175042d75af
--- /dev/null
+++ b/app-emacs/company-mode/company-mode-1.0.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="In-buffer completion front-end"
+HOMEPAGE="https://company-mode.github.io/
+ https://github.com/company-mode/company-mode/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${PN}-company-icons-root.patch" )
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS=( CONTRIBUTING.md README.md NEWS.md )
+
+src_prepare() {
+ elisp_src_prepare
+
+ sed "s|@SITEETC@|${SITEETC}/${PN}|" -i company.el || die
+}
+
+src_compile() {
+ elisp_src_compile
+
+ emake -C doc company.info
+}
+
+src_test() {
+ emake test-batch
+}
+
+src_install() {
+ elisp_src_install
+
+ insinto "${SITEETC}/${PN}"
+ doins -r icons
+
+ doinfo doc/company.info
+}