summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-08-26 20:50:24 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-08-26 21:42:08 +0200
commit64cff620c75ed2afad6b207c1a49637735f2a78c (patch)
tree50de759e806d09cfaf6c5f42bcaa2b96de9e7827 /app-emacs
parentdev-cpp/toml11: new package; add 4.2.0 (diff)
downloadgentoo-64cff620c75ed2afad6b207c1a49637735f2a78c.tar.gz
gentoo-64cff620c75ed2afad6b207c1a49637735f2a78c.tar.bz2
gentoo-64cff620c75ed2afad6b207c1a49637735f2a78c.zip
app-emacs/emacsql: bump to 4.0.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/emacsql/Manifest1
-rw-r--r--app-emacs/emacsql/emacsql-4.0.1.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/app-emacs/emacsql/Manifest b/app-emacs/emacsql/Manifest
index e355feb1fcf3..768407f97421 100644
--- a/app-emacs/emacsql/Manifest
+++ b/app-emacs/emacsql/Manifest
@@ -1,2 +1,3 @@
DIST emacsql-3.1.1.tar.gz 2392710 BLAKE2B 7281c9630c26363d9e88463a3ead8b241a3fc1a5e87cbf855eb233ef6b295ca6ba4ea4a79b5137b27f9eed33012dfaa183dab7be8e76b240305ee921edebe874 SHA512 0ec3890cfa014a0afef23e2e38bcd844527b0a497bbfe6f89cbbb090811d43996074e642f83f7f49b27659fc51a901645a54aac600e9988dcb40fffe86a06fbf
DIST emacsql-4.0.0.tar.gz 2398791 BLAKE2B 55a67c5da79e290ba1024a8704113276d6db9d05e539eba79bded01d4092c3565a50c48608cb0932ad0e06d0b1a378e61cceffc8bb910c03da717c6f0a70e62b SHA512 040d8fc9a28505102791ea203d8cb58520ea871b2abc937a128e7d26eba62e89886094874c69806a3e6e5e01cafff5d9caf699438693b03ccd383aa5f94ae949
+DIST emacsql-4.0.1.tar.gz 2398167 BLAKE2B a88470cf561f50e64e4efc1a291cd55b192a4b8c414cf928f81dc8003aefe3b651cd21ea69a5a11de1c07f9e30edeb000a6e95d760eba44f15381a04f5c96b32 SHA512 3b1d6ced510e4bf0cf71da35279ca962584a1d54ab648795249aa77df7ce230e6ccd849dad498a36901de12827d6a633e5015a00b6e96533e77cdfe001c16e7b
diff --git a/app-emacs/emacsql/emacsql-4.0.1.ebuild b/app-emacs/emacsql/emacsql-4.0.1.ebuild
new file mode 100644
index 000000000000..d95717bb989e
--- /dev/null
+++ b/app-emacs/emacsql/emacsql-4.0.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit edo elisp toolchain-funcs
+
+DESCRIPTION="A high-level Emacs Lisp RDBMS front-end"
+HOMEPAGE="https://github.com/magit/emacsql"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/magit/${PN}.git"
+else
+ SRC_URI="
+ https://github.com/magit/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz
+ "
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Unlicense"
+SLOT="0"
+# TODO(arsen): postgres-pg using app-emacs/pg (unpackaged as of yet)
+IUSE="+sqlite postgres mysql"
+
+DEPEND="
+ sqlite? (
+ dev-db/sqlite:3
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ postgres? (
+ dev-db/postgresql
+ )
+ mysql? (
+ virtual/mysql
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ default
+
+ # Not packaged.
+ rm emacsql-pg.el || die
+
+ local -A backends=(
+ [sqlite]=sqlite
+ [postgres]=psql
+ [mysql]=mysql
+ )
+
+ for useflag in "${!backends[@]}"; do
+ if ! use "${useflag}"; then
+ rm emacsql-"${backends[${useflag}]}".el || die
+ fi
+ done
+}
+
+src_compile() {
+ if use sqlite; then
+ edo $(tc-getCC) -fPIC -Wall -Wextra \
+ $($(tc-getPKG_CONFIG) --cflags --libs sqlite3) \
+ ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o emacsql-sqlite \
+ sqlite/emacsql.c
+ fi
+ elisp_src_compile
+}
+
+src_install() {
+ elisp_src_install
+
+ if use sqlite; then
+ exeinto "${SITELISP}"/emacsql/sqlite
+ doexe emacsql-sqlite
+ fi
+}