summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-28 22:15:23 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-28 22:23:36 +0200
commite5c5e9c60228c3adf81781480a3767358bdf3160 (patch)
treeddc00dc90624542f9d9c8f0306692723dd7ee4cc /app-emacs
parentapp-office/naps2: fix permissions using find (diff)
downloadgentoo-e5c5e9c60228c3adf81781480a3767358bdf3160.tar.gz
gentoo-e5c5e9c60228c3adf81781480a3767358bdf3160.tar.bz2
gentoo-e5c5e9c60228c3adf81781480a3767358bdf3160.zip
app-emacs/gptel: new package; add 0.9.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/gptel/Manifest1
-rw-r--r--app-emacs/gptel/files/50gptel-gentoo.el2
-rw-r--r--app-emacs/gptel/gptel-0.9.0.ebuild43
-rw-r--r--app-emacs/gptel/metadata.xml19
4 files changed, 65 insertions, 0 deletions
diff --git a/app-emacs/gptel/Manifest b/app-emacs/gptel/Manifest
new file mode 100644
index 000000000000..0ccb968c75de
--- /dev/null
+++ b/app-emacs/gptel/Manifest
@@ -0,0 +1 @@
+DIST gptel-0.9.0.tar.gz 75974 BLAKE2B 51bf6ebe754a8fecaa2645d9dba77b844dbc65fbfd430ff67dcaa6b4893c66960f83c8e4344d0fa8b294ba8b468c8ce744fa0f284ed4e87b6e694edb07d2dd14 SHA512 6b7030bc87ef5a9edac547efe62c3392cbca08973eec5f7ace4358b0ad8c25049b69309beec100e6604ed35935468f531f0e0325df65d771819f80826b6b419d
diff --git a/app-emacs/gptel/files/50gptel-gentoo.el b/app-emacs/gptel/files/50gptel-gentoo.el
new file mode 100644
index 000000000000..9fd7e1939754
--- /dev/null
+++ b/app-emacs/gptel/files/50gptel-gentoo.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "@SITELISP@/gptel-autoloads.el" nil t)
diff --git a/app-emacs/gptel/gptel-0.9.0.ebuild b/app-emacs/gptel/gptel-0.9.0.ebuild
new file mode 100644
index 000000000000..783dad3ec302
--- /dev/null
+++ b/app-emacs/gptel/gptel-0.9.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+
+inherit elisp
+
+DESCRIPTION="Simple Large Language Model chat client for GNU Emacs"
+HOMEPAGE="https://github.com/karthink/gptel/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/karthink/${PN}.git"
+else
+ SRC_URI="https://github.com/karthink/${PN}/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ >=app-emacs/compat-30.0.0.0
+ app-emacs/transient
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+DOCS=( README.org )
+SITEFILE="50${PN}-gentoo.el"
+
+elisp-enable-tests ert test -l gptel-org -l gptel-org-test
+
+src_compile() {
+ elisp_src_compile
+ elisp-make-autoload-file
+}
diff --git a/app-emacs/gptel/metadata.xml b/app-emacs/gptel/metadata.xml
new file mode 100644
index 000000000000..6181815e9abe
--- /dev/null
+++ b/app-emacs/gptel/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <longdescription>
+ gptel is a simple Large Language Model chat client for Emacs, with
+ support for multiple models and backends. It works in the spirit of
+ Emacs, available at any time and uniformly in any buffer.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/karthink/gptel/issues/</bugs-to>
+ <remote-id type="github">karthink/gptel</remote-id>
+ </upstream>
+ <stabilize-allarches />
+</pkgmetadata>