summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-02 15:50:47 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-02 15:51:01 -0500
commitbc0e39eeeebd0d78a5e28c50c6d99c65c3b3945d (patch)
tree7432d7f96ab83697a2f7227594648931c1261ccf /app-emulation/cloud-init/cloud-init-20.1.ebuild
parentapp-emulation/diskimage-builder: use DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-bc0e39eeeebd0d78a5e28c50c6d99c65c3b3945d.tar.gz
gentoo-bc0e39eeeebd0d78a5e28c50c6d99c65c3b3945d.tar.bz2
gentoo-bc0e39eeeebd0d78a5e28c50c6d99c65c3b3945d.zip
app-emulation/cloud-init: use DISTUTILS_USE_SETUPTOOLS
closes: https://bugs.gentoo.org/746074 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-emulation/cloud-init/cloud-init-20.1.ebuild')
-rw-r--r--app-emulation/cloud-init/cloud-init-20.1.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/app-emulation/cloud-init/cloud-init-20.1.ebuild b/app-emulation/cloud-init/cloud-init-20.1.ebuild
index 15cdfecdd9cf..2ab63c9b9602 100644
--- a/app-emulation/cloud-init/cloud-init-20.1.ebuild
+++ b/app-emulation/cloud-init/cloud-init-20.1.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -34,7 +35,6 @@ CDEPEND="
dev-python/six[${PYTHON_USEDEP}]
"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
${CDEPEND}
>=dev-python/httpretty-0.7.1[${PYTHON_USEDEP}]