summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2022-12-23 18:42:31 -0500
committerNick Sarnie <sarnex@gentoo.org>2022-12-23 18:44:40 -0500
commitfcda13a18ba7d522b8829558db20770a328b0550 (patch)
treeec06477b8fb8f0155b7e172fd98ba266eca1d8e5 /app-emulation/vendor-reset/vendor-reset-9999.ebuild
parentsci-mathematics/singular: use https mirror in SRC_URI instead of ftp (diff)
downloadgentoo-fcda13a18ba7d522b8829558db20770a328b0550.tar.gz
gentoo-fcda13a18ba7d522b8829558db20770a328b0550.tar.bz2
gentoo-fcda13a18ba7d522b8829558db20770a328b0550.zip
app-emulation/vendor-reset: Improve ebuild
Closes: https://bugs.gentoo.org/884527 Closes: https://bugs.gentoo.org/884529 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'app-emulation/vendor-reset/vendor-reset-9999.ebuild')
-rw-r--r--app-emulation/vendor-reset/vendor-reset-9999.ebuild19
1 files changed, 5 insertions, 14 deletions
diff --git a/app-emulation/vendor-reset/vendor-reset-9999.ebuild b/app-emulation/vendor-reset/vendor-reset-9999.ebuild
index a0b2326fc95a..b82d5b15ad5c 100644
--- a/app-emulation/vendor-reset/vendor-reset-9999.ebuild
+++ b/app-emulation/vendor-reset/vendor-reset-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit linux-mod
+inherit linux-mod toolchain-funcs
if [[ ${PV} == *9999* ]]; then
EGIT_REPO_URI="https://github.com/gnif/vendor-reset.git"
@@ -23,26 +23,17 @@ SLOT="0"
DEPEND=""
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/Respect-eselect-kernel.patch" )
+MODULE_NAMES="vendor-reset(extra)"
pkg_setup() {
local CONFIG_CHECK="FTRACE KPROBES PCI_QUIRKS KALLSYMS FUNCTION_TRACER"
linux-mod_pkg_setup
- export KV_FULL=${KV_FULL}
- export KERNEL_DIR=${KERNEL_DIR}
-}
-
-src_compile() {
- set_arch_to_kernel
- default
+ BUILD_TARGETS="build"
+ BUILD_PARAMS="CC=\"$(tc-getBUILD_CC)\" KDIR=${KERNEL_DIR}"
}
src_install() {
- set_arch_to_kernel
- emake \
- DESTDIR="${ED}" \
- INSTALL_MOD_PATH="${ED}" \
- install
+ linux-mod_src_install
insinto /etc/modules-load.d/
newins "${FILESDIR}"/modload.conf vendor-reset.conf