summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2018-01-20 19:55:04 -0500
committerNP-Hardass <NP-Hardass@gentoo.org>2018-01-22 17:51:12 -0500
commitd61f2aba38b3c298d3beee386b632e9cf4dac69e (patch)
tree3aa07b0cd23a6988514f8f7a1e49b4411b0ee97e /app-emulation/winetricks/winetricks-99999999.ebuild
parentapp-emulation/wine-any: Add maintainer description/warning (diff)
downloadgentoo-d61f2aba38b3c298d3beee386b632e9cf4dac69e.tar.gz
gentoo-d61f2aba38b3c298d3beee386b632e9cf4dac69e.tar.bz2
gentoo-d61f2aba38b3c298d3beee386b632e9cf4dac69e.zip
app-emulation/winetricks: Sync from ::wine
Move test dependencies to DEPEND Bump 20171222 Update comments Add test dependencies Acked-by: Jimi Huotari <chiitoo@gentoo.org> Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-emulation/winetricks/winetricks-99999999.ebuild')
-rw-r--r--app-emulation/winetricks/winetricks-99999999.ebuild26
1 files changed, 19 insertions, 7 deletions
diff --git a/app-emulation/winetricks/winetricks-99999999.ebuild b/app-emulation/winetricks/winetricks-99999999.ebuild
index c6636ccbdade..58d2e71829ba 100644
--- a/app-emulation/winetricks/winetricks-99999999.ebuild
+++ b/app-emulation/winetricks/winetricks-99999999.ebuild
@@ -25,24 +25,32 @@ HOMEPAGE="https://github.com/Winetricks/winetricks https://wiki.winehq.org/Winet
LICENSE="LGPL-2.1+"
SLOT="0"
-IUSE="gtk kde rar"
+IUSE="gtk kde rar test"
+
+DEPEND="test? (
+ dev-python/bashate
+ dev-util/checkbashisms
+ dev-util/shellcheck
+ )"
-DEPEND=""
RDEPEND="app-arch/cabextract
app-arch/p7zip
app-arch/unzip
net-misc/wget
- x11-misc/xdg-utils
virtual/wine
+ x11-misc/xdg-utils
gtk? ( gnome-extra/zenity )
kde? ( kde-apps/kdialog )
rar? ( app-arch/unrar )"
-# Uses non-standard "Wine" category, which is provided by app-emulation/wine; #451552
-QA_DESKTOP_FILE="usr/share/applications/winetricks.desktop"
+# Test targets include syntax checks only, not the "heavy duty" tests
+# that would require a lot of disk space, as well as network access.
-# Tests require network access and run Wine, which is unreliable from a portage environment.
-RESTRICT="test"
+# This uses a non-standard "Wine" category, which is provided by
+# '/etc/xdg/menus/applications-merged/wine.menu' from the
+# 'app-emulation/wine-desktop-common' package.
+# https://bugs.gentoo.org/451552
+QA_DESKTOP_FILE="usr/share/applications/winetricks.desktop"
src_unpack() {
if [[ ${PV} == "99999999" ]] ; then
@@ -55,6 +63,10 @@ src_unpack() {
fi
}
+src_test() {
+ ./tests/shell-checks || die "Test(s) failed."
+}
+
src_install() {
default
if use gtk || use kde; then