summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2015-12-05 23:28:08 -0600
committerDoug Goldstein <cardoe@gentoo.org>2015-12-05 23:35:14 -0600
commit415ca2fc9582e38407e41bb10b4c905e00538661 (patch)
tree4e1d1012e63bf7c8bd6f00f47ef01f8ee0f56329 /app-emulation/xen
parentapp-emulation/xen: provide a sub-slot (diff)
downloadgentoo-415ca2fc9582e38407e41bb10b4c905e00538661.tar.gz
gentoo-415ca2fc9582e38407e41bb10b4c905e00538661.tar.bz2
gentoo-415ca2fc9582e38407e41bb10b4c905e00538661.zip
app-emulation/xen: don't install EFI bits with USE=-efi
Don't install the EFI bits if the user didn't want them. Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/xen-4.6.0-r2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-emulation/xen/xen-4.6.0-r2.ebuild b/app-emulation/xen/xen-4.6.0-r2.ebuild
index 717b3e1e0d4a..b67f6392c185 100644
--- a/app-emulation/xen/xen-4.6.0-r2.ebuild
+++ b/app-emulation/xen/xen-4.6.0-r2.ebuild
@@ -6,7 +6,7 @@ EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit eutils mount-boot flag-o-matic python-any-r1 toolchain-funcs versionator
+inherit eutils multilib mount-boot flag-o-matic python-any-r1 toolchain-funcs versionator
MY_PV=${PV/_/-}
MY_P=${PN}-${PV/_/-}
@@ -170,6 +170,9 @@ src_install() {
fi
emake LDFLAGS="$(raw-ldflags)" DESTDIR="${D}" -C xen ${myopt} install
+
+ # make install likes to throw in some extra EFI bits if it built
+ use efi || rm -rf "${D}/usr/$(get_libdir)/efi"
}
pkg_postinst() {