summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-07-27 15:29:02 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-07-27 15:51:43 +0200
commit498fc6a834f50ff9f734a7c7a2ad1dc2da8c6feb (patch)
treec966e285f051a8b8a780780d5ce62dbd7bfe81fa /app-emulation
parentdev-util/drone: Version bump to 0.8.6 (diff)
downloadgentoo-498fc6a834f50ff9f734a7c7a2ad1dc2da8c6feb.tar.gz
gentoo-498fc6a834f50ff9f734a7c7a2ad1dc2da8c6feb.tar.bz2
gentoo-498fc6a834f50ff9f734a7c7a2ad1dc2da8c6feb.zip
app-emulation/img: Version bump to 0.4.8
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/img/Manifest1
-rw-r--r--app-emulation/img/img-0.4.8.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-emulation/img/Manifest b/app-emulation/img/Manifest
index 39e658277641..af6370df5525 100644
--- a/app-emulation/img/Manifest
+++ b/app-emulation/img/Manifest
@@ -1,2 +1,3 @@
DIST img-0.4.6.tar.gz 5635103 BLAKE2B 88e0ae3bdc0b9e1784d4d67635d119084a5e9dbe258b55da10f549b97f2d566f312226687bef0d28ad1ae3b13c764a44071bfe10ec0a189ad4bcf0bc8c83df5f SHA512 7f75d66237fe5ccf5923774e1d40ef04d9447f3e7de6641167679a1bf5b6305880a046e664fa7adb93dc4bd28e9f0e1ee790ecf2a225aa98b0202e47b8d01987
DIST img-0.4.7.tar.gz 5642840 BLAKE2B 0cff71ad2e3ee7e7a21273bd7171a1cafb51b932a55981081bcd809f62c463e8a58d739ed5e7e46355a596650e272a90b848eb6c1818e948e6512cb07ac5fc5e SHA512 23e059537baedf20c17724f972db2fa2b81677bf7d62ce3f78cabde9984f10923f4fe56d3f02252f578b15e06112066c5ea7e6b41d61554bcafc618cca85d014
+DIST img-0.4.8.tar.gz 5587652 BLAKE2B 5b74ff24e6f36674b66b3f87abe928a9d8c8361835eb61cb04ddfce6bfc7cb7b8e6e1f41d61d9f75c09c3646d0d697074882e1f7b87259b60d7c53303718e325 SHA512 fb5b97c4794798dc2dba5d4c9493da9708a55a9e5e7b2259585409c4e7973fecd362132dabb81c72f20b61956c5a8bc67b58db49c22e7ce56eaec784bbb51ca5
diff --git a/app-emulation/img/img-0.4.8.ebuild b/app-emulation/img/img-0.4.8.ebuild
new file mode 100644
index 000000000000..8c9d8c988abb
--- /dev/null
+++ b/app-emulation/img/img-0.4.8.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/genuinetools/img"
+EGIT_COMMIT="v${PV}"
+GIT_COMMIT="88f96d872335cf2746380fa87ba62fd5b63540b4"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+RESTRICT="test"
+
+src_compile() {
+ local TAGS=$(usex seccomp 'seccomp' '')
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" go build -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc -r src/${EGO_PN}/README.md
+}