summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-09-05 13:43:26 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-09-05 13:45:26 -0500
commit946db4a4aca9bf4d9b7cda7a5c5919ab66b25215 (patch)
tree4ebc5f3314cda7e7553b175609013a502bf2a919 /app-emulation
parentapp-emulation/img: remove old (diff)
downloadgentoo-946db4a4aca9bf4d9b7cda7a5c5919ab66b25215.tar.gz
gentoo-946db4a4aca9bf4d9b7cda7a5c5919ab66b25215.tar.bz2
gentoo-946db4a4aca9bf4d9b7cda7a5c5919ab66b25215.zip
app-emulation/img: drop unnecessary settings
We don't need the -work flag, -s and -w strip the executables and GOCACHE, -v and -x are set in the eclass. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/img/img-0.5.11.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/app-emulation/img/img-0.5.11.ebuild b/app-emulation/img/img-0.5.11.ebuild
index 154fb007ce4b..cd92124e2d1f 100644
--- a/app-emulation/img/img-0.5.11.ebuild
+++ b/app-emulation/img/img-0.5.11.ebuild
@@ -536,10 +536,9 @@ RDEPEND="${DEPEND}
app-emulation/runc"
src_compile() {
- GOCACHE="${T}/go-cache" \
IMG_DISABLE_EMBEDDED_RUNC=1 \
- go build -v -work -x -tags "noembed $(usev seccomp)" \
- -ldflags="-s -w -X version.VERSION=${PV}" || die
+ go build -tags "noembed $(usev seccomp)" \
+ -ldflags="-X version.VERSION=${PV}" || die
}
src_install() {