summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso Josa <nimiux@gentoo.org>2016-03-17 12:46:07 +0100
committerJosé María Alonso Josa <nimiux@gentoo.org>2016-03-17 12:46:49 +0100
commitd56d23414fe0afeb55727b3aeb073b6ec8ad1448 (patch)
tree93295134246002f93825018ee3761e31cc807904 /app-emulation
parentmail-client/thunderbird: ppc64 stable wrt bug #576862 (diff)
downloadgentoo-d56d23414fe0afeb55727b3aeb073b6ec8ad1448.tar.gz
gentoo-d56d23414fe0afeb55727b3aeb073b6ec8ad1448.tar.bz2
gentoo-d56d23414fe0afeb55727b3aeb073b6ec8ad1448.zip
app-emulation/free42: Bump to version 1.5.7
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/free42/Manifest1
-rw-r--r--app-emulation/free42/files/free42-1.5.7-fix-makefile.patch34
-rw-r--r--app-emulation/free42/free42-1.5.7.ebuild46
3 files changed, 81 insertions, 0 deletions
diff --git a/app-emulation/free42/Manifest b/app-emulation/free42/Manifest
index bf0e040da8be..a164de1eafcc 100644
--- a/app-emulation/free42/Manifest
+++ b/app-emulation/free42/Manifest
@@ -1 +1,2 @@
DIST free42-1.5.5.tgz 8160228 SHA256 2c5a16aa470de76185135c307add9b920a712e31269c471dd246b6cf9283e050 SHA512 97833c99a24c2b1f427b237469868d57734b919b6c69521b45de480bd5274f5427caac13b9ccf3b79674d63dabdeda58a8db4c23a184b72b04279acbdf7eff8f WHIRLPOOL d435befbf2d392222d1ef7907c7913e474da5c4997dfb84177be3ea0b3fc1d9c9b0ea41590810e78d38eb082216b28c907fe39613823d866b6a1ab4d531a6af2
+DIST free42-1.5.7.tgz 8159655 SHA256 63c868880e0c18374f4b309dc19e2ea36b9463471d2d77563f53036eea645316 SHA512 fb18712643f73388512fc4dc069d55ef3597f5e6a4e1b47bcd12ab05224027c4ec981ade2398fd8c1e4534003ee6c4de2b7402bade66a3dbe90a46299e7132a3 WHIRLPOOL 0504da8589d3dbf9270a914b2cb6ad86982b926f40abee43d6bbe3f8ec997efe8b0ae50b9d61952e5acd3f2a70d34e16cf0e665cec06d555b0c92438c7a32a43
diff --git a/app-emulation/free42/files/free42-1.5.7-fix-makefile.patch b/app-emulation/free42/files/free42-1.5.7-fix-makefile.patch
new file mode 100644
index 000000000000..ebb99c9d0c1e
--- /dev/null
+++ b/app-emulation/free42/files/free42-1.5.7-fix-makefile.patch
@@ -0,0 +1,34 @@
+diff -Nuar a/gtk/Makefile b/gtk/Makefile
+--- a/gtk/Makefile 2016-02-28 20:14:13.000000000 +0100
++++ b/gtk/Makefile 2016-03-17 12:39:42.679999704 +0100
+@@ -19,7 +19,6 @@
+ -Wall \
+ -Wno-parentheses \
+ -Wno-write-strings \
+- -g \
+ -I/usr/X11R6/include \
+ -fno-exceptions \
+ -fno-rtti \
+@@ -30,18 +29,14 @@
+ -DDECIMAL_GLOBAL_ROUNDING_ACCESS_FUNCTIONS=1 \
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS=1 \
+ -DDECIMAL_GLOBAL_EXCEPTION_FLAGS_ACCESS_FUNCTIONS=1 \
+- -D_WCHAR_T_DEFINED
++ -D_WCHAR_T_DEFINED \
++ ${CXXFLAGS}
+
+-LDFLAGS = -L/usr/X11R6/lib
++LDFLAGS := -L/usr/X11R6/lib ${LDFLAGS}
+ ifeq "$(shell uname -s)" "Darwin"
+ LIBS := gcc111libbid-mac-x64.a -lXmu $(shell pkg-config --libs gtk+-2.0)
+ else
+-LIBS := gcc111libbid-$(shell uname -m).a -lXmu $(shell pkg-config --libs gtk+-2.0)
+-endif
+-
+-ifeq "$(shell uname -s)" "Linux"
+-LDFLAGS += -Wl,--hash-style=both
+-LIBS += -lpthread
++LIBS := gcc111libbid-$(shell uname -m).a -lXmu -lX11 -ldl -lpthread $(shell pkg-config --libs gtk+-2.0)
+ endif
+
+ SRCS = shell_main.cc shell_skin.cc skins.cc keymap.cc shell_loadimage.cc \
diff --git a/app-emulation/free42/free42-1.5.7.ebuild b/app-emulation/free42/free42-1.5.7.ebuild
new file mode 100644
index 000000000000..30caa5df70e9
--- /dev/null
+++ b/app-emulation/free42/free42-1.5.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An HP-42S Calculator Simulator"
+HOMEPAGE="http://thomasokken.com/free42/"
+SRC_URI="mirror://gentoo/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa"
+
+DEPEND="dev-libs/atk
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+ alsa? ( media-libs/alsa-lib )"
+
+RDEPEND="${DEPEND}
+ x11-libs/libX11
+ x11-libs/libXmu"
+
+S="${WORKDIR}/${PN}-nologo-${PV}"
+
+src_prepare() {
+ sed -i -e 's/print_gif_name\[FILENAMELEN\]/print_gif_name\[1000\]/' \
+ "${S}/gtk/shell_main.cc" || die
+ epatch "${FILESDIR}"/${P}-fix-makefile.patch
+}
+
+src_compile() {
+ local myconf
+ use alsa && myconf="AUDIO_ALSA=yes"
+ emake CXX="$(tc-getCXX)" BCD_MATH=1 ${myconf} -C "${S}/gtk"
+}
+
+src_install() {
+ dodoc CREDITS HISTORY README TODO
+ dobin gtk/free42dec
+}