summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-09-11 05:17:30 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-09-14 11:52:35 +0200
commit9a47425ce61a8a4e65fd9ca6b48cd431a783375e (patch)
treefe6fbcf10ca4f4e33871f83abd4da5eab08d06bb /app-forensics
parentdev-util/bear: drop 3.1.3, 3.1.4 (diff)
downloadgentoo-9a47425ce61a8a4e65fd9ca6b48cd431a783375e.tar.gz
gentoo-9a47425ce61a8a4e65fd9ca6b48cd431a783375e.tar.bz2
gentoo-9a47425ce61a8a4e65fd9ca6b48cd431a783375e.zip
app-forensics/yara: add 4.5.2
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/yara/Manifest1
-rw-r--r--app-forensics/yara/yara-4.5.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-forensics/yara/Manifest b/app-forensics/yara/Manifest
index 666b5945eda9..cd03b5021c7c 100644
--- a/app-forensics/yara/Manifest
+++ b/app-forensics/yara/Manifest
@@ -1,2 +1,3 @@
DIST yara-4.5.0.tar.gz 2206492 BLAKE2B 788ed6c4989bbc2d0a113b46bcd1291e7544ab8f56ebe499725163b7b02feb016935210e8a08d9cb179fbffc09fafb461cc55156101d9616a23a480a78862d9e SHA512 c9fe8a89879d1a742236101f1754e6b25e70356cdf5c020b2583e3ac509600c3b462756c412b01f2ebcb17df351c83afcf04d1cfaa87e6753eb25bab0f797aa3
DIST yara-4.5.1.tar.gz 2207552 BLAKE2B b8983371e3ec6f0fd4208698742a576d3c76e1ce34b7ebbc10c7b414f663b570c812c10dce8eefe32f4cf6cffe033bb63a05987068c49e9235077e20d96ca06d SHA512 8bf1df7089f9bc5a448dbae0999e04f4ecdec06b4478e2cb5f42a2a3201b99fce68379e3f8f7c67a9db201205366250d7befe5c38451cced807ed692d436422c
+DIST yara-4.5.2.tar.gz 2207923 BLAKE2B c686ca73f6f7be26cc0dca08964f66051180fdb782510d0cc40aed1d76cac985a6ac4a688e75934865200cc413f050afa308daa1da3adfaeec6155206f7fad85 SHA512 761f3930117c35d87b0e3be1a5d61a6887006470fdf578164feb1bd56a96b2d85770ab7c3a21258a2781ff3327cb705942f4f0eb959cff4b210f0c7fbec1fc30
diff --git a/app-forensics/yara/yara-4.5.2.ebuild b/app-forensics/yara/yara-4.5.2.ebuild
new file mode 100644
index 000000000000..0ceb7748b741
--- /dev/null
+++ b/app-forensics/yara/yara-4.5.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A malware identification and classification tool"
+HOMEPAGE="https://virustotal.github.io/yara/"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/VirusTotal/yara.git"
+else
+ SRC_URI="https://github.com/virustotal/yara/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${PV/_/-}"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0/10"
+IUSE="+dex +dotnet +cuckoo +macho +magic profiling python test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/openssl:=
+ cuckoo? ( dev-libs/jansson:= )
+ magic? ( sys-apps/file:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+PDEPEND="python? ( =dev-python/yara-python-$(ver_cut 1)* )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable profiling) \
+ $(use_enable cuckoo) \
+ $(use_enable magic) \
+ $(use_enable dotnet) \
+ $(use_enable macho) \
+ $(use_enable dex) \
+ $(use_enable test static)
+}
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ default
+
+ # TODO: Allow tests to work against dyn. lib rather than building
+ # statically just for tests.
+ find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
+}