summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-05-31 21:06:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-05-31 21:10:40 +0300
commit916b04ff4db08dcc6cd5fc6931cd69cf641fb7da (patch)
tree8cb5ca9576d99b9fd470dd1e5bd380e4130beb70 /app-i18n
parentdev-python/paho-mqtt: add pypy3 in PYTHON_COMPAT (diff)
downloadgentoo-916b04ff4db08dcc6cd5fc6931cd69cf641fb7da.tar.gz
gentoo-916b04ff4db08dcc6cd5fc6931cd69cf641fb7da.tar.bz2
gentoo-916b04ff4db08dcc6cd5fc6931cd69cf641fb7da.zip
app-i18n/scim-hangul: EAPI=8, fix deps
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim-hangul/scim-hangul-0.4.0-r1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-i18n/scim-hangul/scim-hangul-0.4.0-r1.ebuild b/app-i18n/scim-hangul/scim-hangul-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..c48f5f8fac7c
--- /dev/null
+++ b/app-i18n/scim-hangul/scim-hangul-0.4.0-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Hangul IMEngine for SCIM ported from imhangul"
+HOMEPAGE="http://www.scim-im.org/"
+SRC_URI="https://downloads.sourceforge.net/scim/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+DEPEND="
+ app-accessibility/at-spi2-core:2
+ >=app-i18n/scim-0.99.8
+ >=app-i18n/libhangul-0.0.4:=
+ dev-libs/glib:2
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/harfbuzz:=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/pango
+ nls? ( virtual/libintl )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.2+gcc-4.3.patch
+ "${FILESDIR}"/${PN}-0.3.2+gcc-4.7.patch
+ "${FILESDIR}"/${PN}-0.4.0+gtk.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ --without-included-libltdl
+ --disable-skim-support
+ $(use_enable nls)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ dodoc ChangeLog*
+
+ # plugin module, no point in .la files
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM with both GTK2 and XIM, you should use the following"
+ elog "in your user startup scripts such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog
+}