summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYongxiang Liang <tanekliang@gmail.com>2024-08-19 22:48:21 +0800
committerYixun Lan <dlan@gentoo.org>2024-08-22 11:42:15 +0000
commitb7d5d754da567d002f8a029cec921c4cb5fe8a67 (patch)
tree40a62a82b5db603f19f5443ee98fe0692a6db582 /app-i18n
parentapp-i18n/fcitx-sayura: add 5.1.2 (diff)
downloadgentoo-b7d5d754da567d002f8a029cec921c4cb5fe8a67.tar.gz
gentoo-b7d5d754da567d002f8a029cec921c4cb5fe8a67.tar.bz2
gentoo-b7d5d754da567d002f8a029cec921c4cb5fe8a67.zip
app-i18n/fcitx-unikey: add 5.1.4
Bug: https://bugs.gentoo.org/760501 Closes: https://github.com/gentoo/gentoo/pull/38186 Signed-off-by: Yongxiang Liang <tanekliang@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/fcitx-unikey/Manifest1
-rw-r--r--app-i18n/fcitx-unikey/fcitx-unikey-5.1.4.ebuild50
-rw-r--r--app-i18n/fcitx-unikey/metadata.xml9
3 files changed, 60 insertions, 0 deletions
diff --git a/app-i18n/fcitx-unikey/Manifest b/app-i18n/fcitx-unikey/Manifest
index 7869c92d0088..c694268b1de5 100644
--- a/app-i18n/fcitx-unikey/Manifest
+++ b/app-i18n/fcitx-unikey/Manifest
@@ -1 +1,2 @@
DIST fcitx-unikey-0.2.7.tar.xz 75204 BLAKE2B a0d70747a560b2493a3b7f7e06ff35f7e465bb4c4c8d22cb4db02f70a6298c49780fd0045874faeba1f20ad188a01a81fefc67a4f6ac9d6946d959f731a376a4 SHA512 1bb78e4f27f0cda1e3aa5a633be45e0a26d121d5b472b1325b0c028ff65ca156d23e7ffee0367badeac1dd21ba1743ee8a2c9c27c629ae0996e84e0062b67ad2
+DIST fcitx5-unikey-5.1.4.tar.zst 114482 BLAKE2B daa7cb04f2047e7495f4699c4b7abe711b96553f8339b6ed41f84e934239e935ba55110076fd177fe14a8a5f01b65090fb2bf517acef9d085af018879b10b75a SHA512 d8918222c37609c078bdf6d73a5acaa5ebaf23b4b49d253850c737ac659cee94956ee8782b3ac2ea6eaa5cfdb8fccec6a62e86d6b0a1b4f5b03c4a6e395ca3f0
diff --git a/app-i18n/fcitx-unikey/fcitx-unikey-5.1.4.ebuild b/app-i18n/fcitx-unikey/fcitx-unikey-5.1.4.ebuild
new file mode 100644
index 000000000000..a3ba80268567
--- /dev/null
+++ b/app-i18n/fcitx-unikey/fcitx-unikey-5.1.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="fcitx5-unikey"
+
+inherit cmake unpacker xdg
+
+DESCRIPTION="Unikey (Vietnamese Input Method) engine support for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx5-unikey"
+SRC_URI="https://download.fcitx-im.org/fcitx5/${MY_PN}/${MY_PN}-${PV}.tar.zst"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gui +qt5 qt6 test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=app-i18n/fcitx-5.1.10:5
+ >=app-i18n/fcitx-qt-5.0.12[qt5?,qt6?,-onlyplugin]
+ gui? (
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ )
+ qt6? (
+ dev-qt/qtbase:6[dbus,gui,widgets]
+ )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=( )
+ if use gui; then
+ mycmakeargs+=(
+ -DENABLE_QT=ON
+ -DUSE_QT6=$(usex qt6)
+ )
+ fi
+ cmake_src_configure
+}
diff --git a/app-i18n/fcitx-unikey/metadata.xml b/app-i18n/fcitx-unikey/metadata.xml
index ce4b6e943c2c..d9272badfada 100644
--- a/app-i18n/fcitx-unikey/metadata.xml
+++ b/app-i18n/fcitx-unikey/metadata.xml
@@ -1,6 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>tanekliang@gmail.com</email>
+ <name>Yongxiang Liang</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<maintainer type="project">
<email>cjk@gentoo.org</email>
<name>Cjk</name>
@@ -10,5 +18,6 @@
</use>
<upstream>
<remote-id type="github">fcitx/fcitx-unikey</remote-id>
+ <remote-id type="github">fcitx/fcitx5-unikey</remote-id>
</upstream>
</pkgmetadata>