summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2020-04-04 16:48:18 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-04-09 15:37:42 +0300
commit7d4204df4d78d93e7f5a5c25ca97ce8e6de2f0d2 (patch)
tree6b0ac770e4d366306e483195c21b7daed580d894 /app-leechcraft/lc-azoth
parentapp-leechcraft/lc-aggregator: fix qtsql flags dependencies (diff)
downloadgentoo-7d4204df4d78d93e7f5a5c25ca97ce8e6de2f0d2.tar.gz
gentoo-7d4204df4d78d93e7f5a5c25ca97ce8e6de2f0d2.tar.bz2
gentoo-7d4204df4d78d93e7f5a5c25ca97ce8e6de2f0d2.zip
app-leechcraft/lc-azoth: bump EAPI, add subslot ops
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-leechcraft/lc-azoth')
-rw-r--r--app-leechcraft/lc-azoth/lc-azoth-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild b/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
index 0eadc74c2bcd..79223f027924 100644
--- a/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
+++ b/app-leechcraft/lc-azoth/lc-azoth-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit leechcraft
@@ -37,11 +37,11 @@ COMMON_DEPEND="
)
sarin? (
dev-qt/qtconcurrent:5
- net-libs/tox
+ net-libs/tox:=
)
woodpecker? ( dev-libs/kqoauth )
xmpp? (
- >=net-libs/qxmpp-0.9.3-r1
+ >=net-libs/qxmpp-1.2.0
media? ( net-libs/qxmpp[speex] )
)
xtazy? ( ~app-leechcraft/lc-xtazy-${PV} )
@@ -98,11 +98,11 @@ src_configure() {
-DENABLE_AZOTH_XTAZY=$(usex xtazy)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use doc && dodoc -r "${CMAKE_BUILD_DIR}"/out/html/*
}