summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author0xd34df00d <0xd34df00d@gmail.com>2017-02-25 19:49:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-26 12:58:56 +0100
commit09222bd0523d448c79f1434b042f55e440097adf (patch)
tree899893b57e6ed056d7eb0f4350388ccbedbc6b90 /app-leechcraft/lc-monocle
parentprofiles/arch/hppa: Mask USE=libsecret for dev-vcs/git. (diff)
downloadgentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.gz
gentoo-09222bd0523d448c79f1434b042f55e440097adf.tar.bz2
gentoo-09222bd0523d448c79f1434b042f55e440097adf.zip
app-leechcraft: use Qt5, modernize the eclass and ebuilds
Closes: https://github.com/gentoo/gentoo/pull/4079
Diffstat (limited to 'app-leechcraft/lc-monocle')
-rw-r--r--app-leechcraft/lc-monocle/lc-monocle-9999.ebuild23
-rw-r--r--app-leechcraft/lc-monocle/metadata.xml8
2 files changed, 20 insertions, 11 deletions
diff --git a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
index 62917cfb1a4c..65fe56456d69 100644
--- a/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
+++ b/app-leechcraft/lc-monocle/lc-monocle-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="5"
+EAPI=6
inherit leechcraft
@@ -15,7 +15,12 @@ IUSE="debug +djvu doc +fb2 +mobi +pdf +postscript"
REQUIRED_USE="postscript? ( pdf )"
CDEPEND="~app-leechcraft/lc-core-${PV}
- pdf? ( app-text/poppler[qt4] )
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtxml:5
+ pdf? ( app-text/poppler[qt5] )
djvu? ( app-text/djvu )"
RDEPEND="${CDEPEND}
@@ -26,12 +31,12 @@ DEPEND="${CDEPEND}
src_configure() {
local mycmakeargs=(
- $(cmake-utils_use_enable djvu MONOCLE_SEEN)
- $(cmake-utils_use_with doc DOCS)
- $(cmake-utils_use_enable fb2 MONOCLE_FXB)
- $(cmake-utils_use_enable mobi MONOCLE_DIK)
- $(cmake-utils_use_enable pdf MONOCLE_PDF)
- $(cmake-utils_use_enable postscript MONOCLE_POSTRUS)
+ -DENABLE_MONOCLE_SEEN=$(usex djvu)
+ -DWITH_DOCS=$(usex doc)
+ -DENABLE_MONOCLE_FXB=$(usex fb2)
+ -DENABLE_MONOCLE_DIK=$(usex mobi)
+ -DENABLE_MONOCLE_PDF=$(usex pdf)
+ -DENABLE_MONOCLE_POSTRUS=$(usex postscript)
)
cmake-utils_src_configure
}
diff --git a/app-leechcraft/lc-monocle/metadata.xml b/app-leechcraft/lc-monocle/metadata.xml
index a77f7b5b5061..421dc6dc1773 100644
--- a/app-leechcraft/lc-monocle/metadata.xml
+++ b/app-leechcraft/lc-monocle/metadata.xml
@@ -1,9 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person">
+ <email>0xd34df00d@gmail.com</email>
+ <name>Georg Rudoy</name>
+ </maintainer>
<maintainer type="project">
- <email>leechcraft@gentoo.org</email>
- <name>LeechCraft</name>
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
</maintainer>
<use>
<flag name="fb2">Enable support for FictionBook format</flag>