summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-08-08 11:29:58 -0400
committerTim Harder <radhermit@gentoo.org>2016-08-08 11:29:58 -0400
commitd7319f3a1a111eeec588b0a7b1c4f0847176d2af (patch)
treec5636f6d06fc354622a755e53b597b9906db5f0d /app-misc/jq
parentapp-misc/jq: stabilize 1.5-r2 (diff)
downloadgentoo-d7319f3a1a111eeec588b0a7b1c4f0847176d2af.tar.gz
gentoo-d7319f3a1a111eeec588b0a7b1c4f0847176d2af.tar.bz2
gentoo-d7319f3a1a111eeec588b0a7b1c4f0847176d2af.zip
app-misc/jq: remove old
Diffstat (limited to 'app-misc/jq')
-rw-r--r--app-misc/jq/Manifest1
-rw-r--r--app-misc/jq/files/jq-1.4-dynamic-link.patch12
-rw-r--r--app-misc/jq/jq-1.4-r1.ebuild40
-rw-r--r--app-misc/jq/jq-1.4.ebuild32
-rw-r--r--app-misc/jq/jq-1.5-r1.ebuild53
5 files changed, 0 insertions, 138 deletions
diff --git a/app-misc/jq/Manifest b/app-misc/jq/Manifest
index e3acfd5834dd..10a1e83dde30 100644
--- a/app-misc/jq/Manifest
+++ b/app-misc/jq/Manifest
@@ -1,2 +1 @@
-DIST jq-1.4.tar.gz 578317 SHA256 998c41babeb57b4304e65b4eb73094279b3ab1e63801b6b4bddd487ce009b39d SHA512 02e601b713a3249bcfe5373153dff38a63bf504895181ca3f691dbf033b407373a9c5880001bbd1954123cdf89f4fe75e2a5168e7a7cf13b3f7355dc18f92458 WHIRLPOOL 93c85a40d8aaf36d1f846ee9050aebe32a3a135e89a64647688b447af8733d210a4716d4ee62271a7d33f2e498e8aee7b2e88ed5373d0ec07e810215c1d288ab
DIST jq-1.5.tar.gz 739309 SHA256 c4d2bfec6436341113419debf479d833692cc5cdab7eb0326b5a4d4fbe9f493c SHA512 4a0bb069ae875f47731d7d84ae6b82240703dc7a694cfb0aee4c7e9639defe7ba9af575d17dc32bda4426b80c186cc8dcd4505f3a6bcbe16b39e9b13097da238 WHIRLPOOL ca45763fb43ba0bc4a97f1a6d34e3c5af0f25f2548d04646f76ac18e95792445eaa42869ce4a7a736b7d6bc09440225e277df79abacf23ef3c8f1b41170e2907
diff --git a/app-misc/jq/files/jq-1.4-dynamic-link.patch b/app-misc/jq/files/jq-1.4-dynamic-link.patch
deleted file mode 100644
index b958a1556125..000000000000
--- a/app-misc/jq/files/jq-1.4-dynamic-link.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-do not statically link libjq since we install it
-
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -53,7 +53,6 @@
-
- bin_PROGRAMS = jq
- jq_SOURCES = main.c
--jq_LDFLAGS = -static-libtool-libs
- jq_LDADD = libjq.la -lm
-
- ### Tests (make check)
diff --git a/app-misc/jq/jq-1.4-r1.ebuild b/app-misc/jq/jq-1.4-r1.ebuild
deleted file mode 100644
index 478241412cd2..000000000000
--- a/app-misc/jq/jq-1.4-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools eutils
-
-DESCRIPTION="A lightweight and flexible command-line JSON processor"
-HOMEPAGE="https://stedolan.github.com/jq/"
-SRC_URI="https://github.com/stedolan/jq/releases/download/${P}/${P}.tar.gz"
-
-LICENSE="MIT CC-BY-3.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="static-libs test"
-
-DEPEND="sys-devel/bison
- sys-devel/flex
- test? ( dev-util/valgrind )"
-
-DOCS=( AUTHORS README )
-
-src_prepare() {
- sed -i '/^dist_doc_DATA/d' Makefile.am || die
- epatch "${FILESDIR}"/${PN}-1.4-dynamic-link.patch
- eautoreconf
-}
-
-src_configure() {
- # don't try to rebuild docs
- econf \
- --disable-docs \
- $(use_enable static-libs static)
-}
-
-src_install() {
- default
- use static-libs || find "${ED}" -name libjq.la -delete
-}
diff --git a/app-misc/jq/jq-1.4.ebuild b/app-misc/jq/jq-1.4.ebuild
deleted file mode 100644
index 34a272633f21..000000000000
--- a/app-misc/jq/jq-1.4.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools eutils
-
-DESCRIPTION="A lightweight and flexible command-line JSON processor"
-HOMEPAGE="https://stedolan.github.com/jq/"
-SRC_URI="https://github.com/stedolan/jq/releases/download/${P}/${P}.tar.gz"
-
-LICENSE="MIT CC-BY-3.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-
-DEPEND="sys-devel/bison
- sys-devel/flex
- test? ( dev-util/valgrind )"
-
-DOCS=( AUTHORS README )
-
-src_prepare() {
- sed -i '/^dist_doc_DATA/d' Makefile.am || die
- eautoreconf
-}
-
-src_configure() {
- # don't try to rebuild docs
- econf --disable-docs
-}
diff --git a/app-misc/jq/jq-1.5-r1.ebuild b/app-misc/jq/jq-1.5-r1.ebuild
deleted file mode 100644
index df24e2f78f45..000000000000
--- a/app-misc/jq/jq-1.5-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="A lightweight and flexible command-line JSON processor"
-HOMEPAGE="https://stedolan.github.com/jq/"
-SRC_URI="https://github.com/stedolan/jq/releases/download/${P}/${P}.tar.gz"
-
-LICENSE="MIT CC-BY-3.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x64-macos"
-IUSE="oniguruma static-libs test"
-
-DEPEND=">=sys-devel/bison-3.0
- sys-devel/flex
- oniguruma? ( dev-libs/oniguruma[static-libs?] )
- test? ( dev-util/valgrind )"
-RDEPEND="!static-libs? (
- oniguruma? ( dev-libs/oniguruma[static-libs?] )
- )"
-
-DOCS=( AUTHORS README )
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.5-dynamic-link.patch
- "${FILESDIR}"/${P}-remove-automagic-dep-on-oniguruma.patch
-)
-
-src_prepare() {
- sed -i '/^dist_doc_DATA/d' Makefile.am || die
- sed -i -r "s:(m4_define\(\[jq_version\],) .+\):\1 \[${PV}\]):" \
- configure.ac || die
-
- default
- eautoreconf
-}
-
-src_configure() {
- # don't try to rebuild docs
- econf \
- --disable-docs \
- $(use_enable static-libs static) \
- $(use_with oniguruma)
-}
-
-src_install() {
- default
- use static-libs || find "${ED}" -name libjq.la -delete
-}