summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2022-10-05 22:52:37 -0700
committerJoonas Niilola <juippis@gentoo.org>2022-11-10 18:15:33 +0200
commit2284183356188a3535a1f73f0129c4c5a1d7e089 (patch)
tree16eecd71158193f63a67f8c0208bf2cbb7487312 /app-misc/trash-cli
parentapp-dicts/myspell-uk: bump to version 5.9.0 (diff)
downloadgentoo-2284183356188a3535a1f73f0129c4c5a1d7e089.tar.gz
gentoo-2284183356188a3535a1f73f0129c4c5a1d7e089.tar.bz2
gentoo-2284183356188a3535a1f73f0129c4c5a1d7e089.zip
app-misc/trash-cli: add 0.22.8.27
Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/trash-cli')
-rw-r--r--app-misc/trash-cli/Manifest1
-rw-r--r--app-misc/trash-cli/trash-cli-0.22.8.27.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/trash-cli/Manifest b/app-misc/trash-cli/Manifest
index 4098df1d8a0b..3e0dd02959f7 100644
--- a/app-misc/trash-cli/Manifest
+++ b/app-misc/trash-cli/Manifest
@@ -1,2 +1,3 @@
DIST trash-cli-0.22.4.16.tar.gz 78221 BLAKE2B 9eabecf5b4e787e1a413f4b05fb6c5592b4a5ec55e4a399c02c738e2ad62acaabc234217954262a79c85ad855535a2ca0d6f981b0ac86139f6c631519aeea936 SHA512 961e87ec361c405a45d02e6a4b7bf43493bca86cf3540a7235df459abd450762bcea4760acdfed0e5f276933ff0eb5b9f426ae0eecfde3e5830a8699fa99a19f
DIST trash-cli-0.22.8.21.tar.gz 79315 BLAKE2B a4b0f3072d9a9091b90bec13e3a8208c58638f7dd054a788ba0126f8c803748c837dbf183513ca87a775d4efbed9e926603b2b3839f9f499963b774f59f06cd5 SHA512 9c8a40cd92c070dfcadfe2a4871c16a3cfc066568f0e079e11ff80aff53777335f1fec42245846bba04866a55ba9d11a2493950ccdcefcd7d98825508eb6ab6b
+DIST trash-cli-0.22.8.27.tar.gz 80344 BLAKE2B 309a1c429b6e052d622f5cd0f4eb211e1dcf8f5fcbe0834d359cd568527843e6a3c4cd1d61f1d1102b6e7f5b7a55fdde396b2500ca94f9410111705cdbff339b SHA512 909a521f40e2252012ed9ebafe8baff50cd2f743c9ab49df0abb41ecc177e551bde07289505f37e8dc86a0d20cdc8b521c35dd2383d17d4f9e962aa431368fe8
diff --git a/app-misc/trash-cli/trash-cli-0.22.8.27.ebuild b/app-misc/trash-cli/trash-cli-0.22.8.27.ebuild
new file mode 100644
index 000000000000..641302d9ab3e
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.22.8.27.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}