summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-16 15:13:34 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-24 10:36:46 +0100
commit9d5a63064b6749e767dc59431c493d68efa0effe (patch)
treefddb5f4914022501d1aaeaaf12355a083d86d943 /app-misc
parentapp-misc/ddcutil: add 1.4.5 (diff)
downloadgentoo-9d5a63064b6749e767dc59431c493d68efa0effe.tar.gz
gentoo-9d5a63064b6749e767dc59431c493d68efa0effe.tar.bz2
gentoo-9d5a63064b6749e767dc59431c493d68efa0effe.zip
app-misc/ddcutil: add 2.0.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/ddcutil/Manifest1
-rw-r--r--app-misc/ddcutil/ddcutil-2.0.0.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/app-misc/ddcutil/Manifest b/app-misc/ddcutil/Manifest
index cdb55c4e86ff..c259a8321369 100644
--- a/app-misc/ddcutil/Manifest
+++ b/app-misc/ddcutil/Manifest
@@ -2,3 +2,4 @@ DIST ddcutil-1.2.2.tar.gz 803943 BLAKE2B 65cc5dc0d1ee85d1e2b6670f7c24508ab817c6e
DIST ddcutil-1.3.0.tar.gz 816789 BLAKE2B 1cb3b64961503416b85b792e1002ec67788f8cf7d622be1c4930808f99e16974ff57ed582d1d02a67580e3f4d92bef54b3669fd7378462bf4c98a3643d6786be SHA512 93d69958b2e1dcb66ad700712742536179383c93f2ec1f746b6a6c78adfd6daa861275208850cc807e0c16a11ea84904cb13ceef512ca76e1daa910410303d41
DIST ddcutil-1.4.1.tar.gz 816782 BLAKE2B ebc8b8893fda9a1e5b278b198594619f7c26a309e15aab90d5f8c61da352c54173076c86ce4e9d9bdcad8857e8ee45500de0c28d5de073038c841caf12080e5f SHA512 e53820662c12cd3a91b1182e02ad74841238117c129e88c8bcdede42d4e0dec22a9c1ec37a7b1e1dd512f2cf7ef410e737d9fdba62d95ea48e5912e43e6d3857
DIST ddcutil-1.4.5.tar.gz 817492 BLAKE2B b6442d9f7ec3687a3e75d9784dc9f62563f42c72c82a8a2ea24a392c3c4f186578c2c2f6592ba12c324568a20b7b25082acce9e7b753c41c1ac925d9d6de62dd SHA512 c355f104b60dbc3c893dea473d841181cfcaacd0cb2e97bc41ea829185c7ccdcff19ab19189ee572e7f2f6b41cbb2bd6c569ad3c09f6d645f9e342b7d1a5310f
+DIST ddcutil-2.0.0.tar.gz 882984 BLAKE2B 19f92ab7fb02130c84e029a8055fe85ea99b9bd2959ad3c86b698afba9a45844817c0828fd2ad3178b954493a12dc62e95815e2700a42d37c340f098ad9d3f16 SHA512 e1880cf0e3e724f6ac88f807a867a34f451422b58ce7d23bee7b2fc40b253ef8de13df7706749e0c8242fe5de6db8da91784d16fbf008bb5161732a598c3b9e7
diff --git a/app-misc/ddcutil/ddcutil-2.0.0.ebuild b/app-misc/ddcutil/ddcutil-2.0.0.ebuild
new file mode 100644
index 000000000000..708539105ec7
--- /dev/null
+++ b/app-misc/ddcutil/ddcutil-2.0.0.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Check for bumps & cleanup with app-misc/ddcui
+
+inherit autotools linux-info udev
+
+DESCRIPTION="Program for querying and changing monitor settings"
+HOMEPAGE="https://www.ddcutil.com/"
+SRC_URI="https://github.com/rockowitz/ddcutil/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/5"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="drm usb-monitor user-permissions video_cards_nvidia X"
+REQUIRED_USE="drm? ( X )"
+
+RDEPEND="
+ dev-libs/glib:2
+ sys-apps/i2c-tools
+ virtual/udev
+ drm? ( x11-libs/libdrm )
+ usb-monitor? (
+ dev-libs/hidapi
+ virtual/libusb:1
+ sys-apps/usbutils
+ )
+ user-permissions? (
+ acct-group/i2c
+ usb-monitor? ( acct-group/video )
+ )
+ X? (
+ x11-libs/libXrandr
+ x11-libs/libX11
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+# doc? ( app-doc/doxygen[dot] )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.1-no-werror.patch
+)
+
+pkg_pretend() {
+ # This program needs /dev/ic2-* devices to communicate with the monitor.
+ CONFIG_CHECK="~I2C_CHARDEV"
+ ERROR_I2C_CHARDEV="You must enable I2C_CHARDEV in your kernel to continue"
+ if use usb-monitor; then
+ CONFIG_CHECK+=" ~HIDRAW ~USB_HIDDEV"
+ ERROR_HIDRAW="HIDRAW is needed to support USB monitors"
+ ERROR_I2C_CHARDEV="USB_HIDDEV is needed to support USB monitors"
+ fi
+
+ # Now do the actual checks setup above
+ check_extra_config
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ # FAILS: doxyfile: No such file or directory
+ # $(use_enable doc doxygen)
+ $(use_enable drm)
+ --enable-udev
+ $(use_enable usb-monitor usb)
+ --enable-lib
+ $(use_enable X x11)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ if use user-permissions; then
+ udev_dorules data/etc/udev/rules.d/60-ddcutil-i2c.rules
+ if use usb-monitor; then
+ udev_dorules data/etc/udev/rules.d/60-ddcutil-usb.rules
+ fi
+ fi
+}
+
+pkg_postinst() {
+ if use user-permissions; then
+ einfo "To allow non-root users access to the /dev/i2c-* devices, add those"
+ einfo "users to the i2c group: usermod -aG i2c user"
+ einfo "Restart the computer or reload the i2c-dev module to activate"
+ einfo "the new udev rule."
+ einfo "For more information read: http://www.ddcutil.com/i2c_permissions/"
+
+ if use usb-monitor; then
+ einfo "To allow non-root users access to USB monitors, add those users"
+ einfo "to the video group: usermod -aG video user"
+ einfo "Restart the computer, reload the hiddev and hidraw modules, or replug"
+ einfo "the monitor to activate the new udev rule."
+ einfo "For more information read: http://www.ddcutil.com/usb/"
+ fi
+
+ udev_reload
+ fi
+
+ if use video_cards_nvidia; then
+ ewarn "Please read the following webpage on proper usage with the nVidia "
+ ewarn "binary drivers, or it may not work: http://www.ddcutil.com/nvidia/"
+ fi
+}
+
+pkg_postrm() {
+ if use user-permissions; then
+ udev_reload
+ fi
+}