summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Brandt <poncho@spahan.ch>2023-02-23 09:37:28 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-02-23 14:28:54 +0200
commit6223196735b3cc35f95944c49ef6ca448ca9f8f4 (patch)
tree0f6b9689ac7bba6f0fcf2d0be8347a22ec8033d4 /app-office/homebank/homebank-5.6.2.ebuild
parentdev-db/sqlite: add 3.41.0 (diff)
downloadgentoo-6223196735b3cc35f95944c49ef6ca448ca9f8f4.tar.gz
gentoo-6223196735b3cc35f95944c49ef6ca448ca9f8f4.tar.bz2
gentoo-6223196735b3cc35f95944c49ef6ca448ca9f8f4.zip
app-office/homebank: add 5.6.2
Closes: https://github.com/gentoo/gentoo/pull/29738 Signed-off-by: Daniel Brandt <poncho@spahan.ch> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-office/homebank/homebank-5.6.2.ebuild')
-rw-r--r--app-office/homebank/homebank-5.6.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-office/homebank/homebank-5.6.2.ebuild b/app-office/homebank/homebank-5.6.2.ebuild
new file mode 100644
index 000000000000..2e1c67a5408b
--- /dev/null
+++ b/app-office/homebank/homebank-5.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit xdg
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="http://homebank.free.fr/index.php"
+SRC_URI="http://homebank.free.fr/public/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ofx"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.39:2
+ >=net-libs/libsoup-2.26:2.4
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/pango
+ ofx? ( >=dev-libs/libofx-0.8.3:= )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND=">=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ >=dev-util/intltool-0.40.5
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ econf $(use_with ofx)
+}