summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-23 01:14:08 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-23 01:18:25 +0200
commit6af80970fc5d72a0cef4e89be4878bd0d34550d7 (patch)
tree33907c08f3ad4d9d8a4a94f10c44db344d1ae257 /app-office/moneydance
parentsys-kernel/gentoo-sources: amd64 stable (bug #738000) (diff)
downloadgentoo-6af80970fc5d72a0cef4e89be4878bd0d34550d7.tar.gz
gentoo-6af80970fc5d72a0cef4e89be4878bd0d34550d7.tar.bz2
gentoo-6af80970fc5d72a0cef4e89be4878bd0d34550d7.zip
app-office/moneydance: bump to version 2020.0.1919
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-office/moneydance')
-rw-r--r--app-office/moneydance/Manifest1
-rw-r--r--app-office/moneydance/moneydance-2020.0.1919.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-office/moneydance/Manifest b/app-office/moneydance/Manifest
index 3a7aded6d6fd..3fbd2e5947d8 100644
--- a/app-office/moneydance/Manifest
+++ b/app-office/moneydance/Manifest
@@ -1,3 +1,4 @@
DIST moneydance-2017.10-amd64.tar.gz 132116528 BLAKE2B f5ba44a89944657c6c1380226dc512729825b084783e6d70dd7b2b731411294c7333bae858b2be3d5321e5145230257b325dc2b72a22744a877673c1c934d854 SHA512 175ff470b5fb5c3851eae708cc641777d7bdf1ede40366ccf5a135d6c813c08d9ce32665a2307c3aefa63eeb2206ad0874cb989aa998415abb86184a2b114ce8
DIST moneydance-2017.10-x86.tar.gz 134860964 BLAKE2B 92181a6c6a81063377823b0fd9ed652036cf1f633c2cab57f19d1dbb18a2542361fc2bafab8852c11b941a24532f662351ea2d05bc928818db24a4cf3cae7112 SHA512 18d9d4ce7b0b65566ac81fea66ba34d66173559ca90ac166cc9b90631400845ae1c9d92ae781a618cacc57cd4f630f079736101d29b66d9c6cee7d32c7c15c22
DIST moneydance-2019.3.1880-amd64.tar.gz 134414524 BLAKE2B fa6991b245efb76d9af17611ce5f24c4c77fe171417f41ccdccccbfa0b6795fbcb1c56c072dc7382e85f81ec57302040eb0cb091162964026fd230e6b5b3eecd SHA512 1e0cedb759168123de357cf4f69691ac4bd9868524d012f924d00c8f653a3505d3defe8c79e0c151d2b9163dfa40b551b0cc86fd7da678e841902bab812a1d2c
+DIST moneydance-2020.0.1919-amd64.tar.gz 146128581 BLAKE2B a7c2bfd940b4203beeaaeefd018746920f26c6902a9b942f7498fbd1184a5c5d5363d2b46238119b8dcbd963c1b584ab66f1101825ac1f31157a4907938557dc SHA512 c67b284f610fe14809bf1382371fba72e792f938e12ef1b8ee032b161a2547cad3579d5b0d41644566b37f35591d42d77a4fdc3515bb95da772054ac10c083f6
diff --git a/app-office/moneydance/moneydance-2020.0.1919.ebuild b/app-office/moneydance/moneydance-2020.0.1919.ebuild
new file mode 100644
index 000000000000..0e4d364fca1f
--- /dev/null
+++ b/app-office/moneydance/moneydance-2020.0.1919.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2018-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop java-pkg-2 xdg-utils
+
+MY_PN="Moneydance"
+MY_PV="$(ver_cut 1-2)_$(ver_cut 3)"
+
+DESCRIPTION="A cross-platform personal finance application"
+HOMEPAGE="https://moneydance.com/"
+SRC_URI="https://infinitekind.com/stabledl/${MY_PV}/${MY_PN}_linux_amd64.tar.gz -> ${P}-amd64.tar.gz"
+
+LICENSE="Apache-1.0 Apache-2.0 BSD CPAL-1.0 CPL-1.0 CSL-2.0 LGPL-2 MIT TIK"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="|| (
+ >=dev-java/openjdk-bin-11.0
+ >=dev-java/openjdk-11.0
+ )
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+RESTRICT="bindist fetch mirror"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://infinitekind.com/stabledl/${MY_PV}/${MY_PN}_linux_amd64.tar.gz"
+ elog "and place it in your DISTDIR directory."
+ elog ""
+ elog "Please keep in mind, that you have to rename the download to ${P}-amd64.tar.gz."
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ java-pkg_dojar lib/*.jar
+
+ newbin "${FILESDIR}/moneydance-bin" moneydance
+
+ local iconsizes="32 128 512"
+ for iconsize in ${iconsizes}; do
+ newicon -s ${iconsize} resources/moneydance_icon${iconsize}.png moneydance.png
+ done
+
+ make_desktop_entry "moneydance" "Moneydance" moneydance Office
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}