summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-11-13 16:25:18 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-11-13 19:07:06 +0100
commite266009a18d5503c66d8b9fc1580c20f025cfaaf (patch)
tree618fbc86d07ffd492559bee6451dfa637ad56875 /app-office
parentdev-lang/nprolog: bump to 3.40 (diff)
downloadgentoo-e266009a18d5503c66d8b9fc1580c20f025cfaaf.tar.gz
gentoo-e266009a18d5503c66d8b9fc1580c20f025cfaaf.tar.bz2
gentoo-e266009a18d5503c66d8b9fc1580c20f025cfaaf.zip
app-office/joplin-desktop: bump to 3.1.24
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-office')
-rw-r--r--app-office/joplin-desktop/Manifest1
-rw-r--r--app-office/joplin-desktop/joplin-desktop-3.1.24.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/app-office/joplin-desktop/Manifest b/app-office/joplin-desktop/Manifest
index 9956fde3c6a1..4bd0166880df 100644
--- a/app-office/joplin-desktop/Manifest
+++ b/app-office/joplin-desktop/Manifest
@@ -1,3 +1,4 @@
DIST Joplin-3.1.20.AppImage 244577745 BLAKE2B b0d0ad00cd1967669a75428090d0fbd8f6dd0aeda68f3d21c03d72264c2cdb6c3a7429db886c76ee00ba608a806512accbd2a6bf5e0b57e36e10b854ba693d14 SHA512 f078d7df5c3733b54aa6d35a8f77b4c4edc06149deebae0bd97d398721afde69f841f7d039e4d069642aa8c461366c26561a978934c9be232464dfc4501332b2
DIST Joplin-3.1.23.AppImage 244602125 BLAKE2B b344accd0fa80240c11074acab90c46b91d4e9c294087663d8cd0f4353649cf1631828cf2ba7d89b5156cfdc80bbee3e37d4dc988359ff3c4f2ea6cbc52f607e SHA512 ec917be832a7c0c33033a4ee1a7f85cefdaa6f07ab735af54689fd4ffc70477c6b4a8e31add3b1c85ccff6df7e613b338bf1d67c395dfd113948f594b2da34fe
+DIST Joplin-3.1.24.AppImage 244603841 BLAKE2B 2175019cbcca58473fb9b7f6157f001ca3c36ede16cc62191c165c3852496dfabb811fc3507ab2e0c5981959e9be50bc8836d0108cc9c80969f6ce0f511f130a SHA512 e286186c07f64ca70f13a95584fa49b7c8ac97bb025c288ca5b15b8334f9ea52ed758cc272c3e6c277544785b02f24423f8af9191973245faef1974791a7366c
DIST Joplin-3.1.3.AppImage 241399868 BLAKE2B a8a6960788dd0e703387fa3e88722513d6a394d4b347b6a69e0cf0079c2e4ce276e21fac60fe9a7a8f573259cdce5dc19dd871c06b6faffeedf5f6ded874a930 SHA512 b49bfed97bcc2210ef6c74d5a431d0620fe43332418486cc854e2f525c9e93d62682a732a03e977ed42ca55eabcde5e897406c3ecf4cc6d86fa6e333a71b9345
diff --git a/app-office/joplin-desktop/joplin-desktop-3.1.24.ebuild b/app-office/joplin-desktop/joplin-desktop-3.1.24.ebuild
new file mode 100644
index 000000000000..64c2fd46b4e0
--- /dev/null
+++ b/app-office/joplin-desktop/joplin-desktop-3.1.24.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# NOTICE: This is a Electron app (oh my) and the upstream only provides AppImages.
+
+EAPI=8
+
+APPIMAGE="Joplin-${PV}.AppImage"
+
+inherit desktop xdg
+
+DESCRIPTION="Secure note taking and to-do app with synchronization capabilities"
+HOMEPAGE="https://joplinapp.org/
+ https://github.com/laurent22/joplin/"
+SRC_URI="https://github.com/laurent22/joplin/releases/download/v${PV}/${APPIMAGE}"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+RESTRICT="bindist"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ app-crypt/libsecret[crypt]
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ media-libs/alsa-lib
+ || (
+ media-libs/libcanberra-gtk3
+ media-libs/libcanberra[gtk3(-)]
+ )
+ media-libs/libglvnd
+ media-libs/mesa
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/zlib
+ sys-process/lsof
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libxkbcommon
+ x11-libs/libxkbfile
+ x11-libs/libXrandr
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+ x11-misc/xdg-utils
+"
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ mkdir -p "${S}" || die
+ cp "${DISTDIR}/${APPIMAGE}" "${S}" || die
+
+ cd "${S}" || die # "appimage-extract" unpacks to current directory.
+ chmod +x "${S}/${APPIMAGE}" || die
+ "${S}/${APPIMAGE}" --appimage-extract || die
+}
+
+src_prepare() {
+ # Fix permissions.
+ find "${S}" -type d -exec chmod a+rx {} + || die
+ find "${S}" -type f -exec chmod a+r {} + || die
+
+ default
+}
+
+src_install() {
+ cd "${S}/squashfs-root" || die
+
+ insinto /usr/share
+ doins -r ./usr/share/icons
+
+ local apphome="/opt/${PN}"
+ local toremove=(
+ .DirIcon
+ @joplinapp-desktop.desktop
+ @joplinapp-desktop.png
+ AppRun
+ LICENSE.electron.txt
+ LICENSES.chromium.html
+ resources/app.asar.unpacked/node_modules/7zip-bin-linux/arm
+ resources/app.asar.unpacked/node_modules/7zip-bin-linux/arm64
+ resources/app.asar.unpacked/node_modules/node-notifier
+ usr
+ )
+ rm -f -r "${toremove[@]}" || die
+
+ mkdir -p "${ED}/${apphome}" || die
+ cp -r . "${ED}/${apphome}" || die
+
+ dosym -r "${apphome}/@joplinapp-desktop" "/usr/bin/${PN}"
+ make_desktop_entry "${PN}" Joplin @joplinapp-desktop "Office;" \
+ "StartupWMClass=Joplin\nMimeType=x-scheme-handler/joplin;"
+}