summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2022-06-06 15:33:10 +0200
committerUlrich Müller <ulm@gentoo.org>2022-06-06 15:34:52 +0200
commit5ab00d5bd484168cf51d6ad0524260456ba9f867 (patch)
tree0810d3e5265ee1fa32ce13e1cbd326c4c23d483a /app-portage/elicense
parentx11-wm/fvwm3: forward keyword to live ebuild (diff)
downloadgentoo-5ab00d5bd484168cf51d6ad0524260456ba9f867.tar.gz
gentoo-5ab00d5bd484168cf51d6ad0524260456ba9f867.tar.bz2
gentoo-5ab00d5bd484168cf51d6ad0524260456ba9f867.zip
app-portage/elicense: Drop live version
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-portage/elicense')
-rw-r--r--app-portage/elicense/elicense-9999.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/app-portage/elicense/elicense-9999.ebuild b/app-portage/elicense/elicense-9999.ebuild
deleted file mode 100644
index 6028d25eb4ee..000000000000
--- a/app-portage/elicense/elicense-9999.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/Whissi/elicense.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/Whissi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-fi
-
-DESCRIPTION="Tool to find installed packages in Gentoo with non-accepted license(s)"
-HOMEPAGE="https://github.com/Whissi/elicense"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-RDEPEND=">=sys-apps/portage-2.3.62[${PYTHON_USEDEP}]"
-
-src_prepare() {
- default
-
- local MY_PV=${PV}
- if [[ ${PV} == "9999" ]]; then
- local last_commit=$(git rev-parse HEAD)
- MY_PV="${last_commit:0:7}-git"
- fi
-
- sed -i -e "s/^MY_PV =.*$/MY_PV = \"${MY_PV}\"/" \
- elicense || die "Failed to sed in version."
-}