summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Puck Neuwirth <alexander@neuwirth-informatik.de>2024-12-04 20:27:00 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-12-05 15:59:11 +0100
commitf3dfd8f0d151379f93dfdac49649cefbe41d65fa (patch)
tree82358ce042eeef5e4e8712fd6cc679ff5d40179e /app-portage/pkg-testing-tools
parentnet-analyzer/pontos: enable py3.13 (diff)
downloadgentoo-f3dfd8f0d151379f93dfdac49649cefbe41d65fa.tar.gz
gentoo-f3dfd8f0d151379f93dfdac49649cefbe41d65fa.tar.bz2
gentoo-f3dfd8f0d151379f93dfdac49649cefbe41d65fa.zip
app-portage/pkg-testing-tools: add 0.2.6
Signed-off-by: Alexander Puck Neuwirth <alexander@neuwirth-informatik.de> Closes: https://github.com/gentoo/gentoo/pull/39595 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-portage/pkg-testing-tools')
-rw-r--r--app-portage/pkg-testing-tools/Manifest1
-rw-r--r--app-portage/pkg-testing-tools/pkg-testing-tools-0.2.6.ebuild32
-rw-r--r--app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild4
3 files changed, 35 insertions, 2 deletions
diff --git a/app-portage/pkg-testing-tools/Manifest b/app-portage/pkg-testing-tools/Manifest
index 0079ccd911aa..751a14f4f35a 100644
--- a/app-portage/pkg-testing-tools/Manifest
+++ b/app-portage/pkg-testing-tools/Manifest
@@ -1 +1,2 @@
DIST pkg-testing-tools-0.2.5.gh.tar.gz 12870 BLAKE2B 5ed2c55522212c00b7cc4919b38f94e32c5fbd63e9386b6b45ca1245ba738678e17d2e6d460e736a2e10da2b546ad7b054e5a2a339c45000d628f59d05a49a46 SHA512 0f1379222134e87068581fe33cdb875e2d6804b663c8203e437a3bf685a1def44512067c04ddd585902ef63c5585ee8ac7c8466f49df77c09e1f7af3bb6744d3
+DIST pkg-testing-tools-0.2.6.gh.tar.gz 13068 BLAKE2B b0a01fab453ac2f5c73ed3bed0c324df4b74314ead3c38a06f26fc5a3c277fc4b2be1870e5552703e023882633ea164d6dd9b36bc338197cd519ca64e966985d SHA512 ec83644ffed01af86dbed056a0c5e78a737ee52046f8cc1b303af73f42deb9851d43521809305972117689e0545812b67c6375164add45122ed36a648ff816df
diff --git a/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.6.ebuild b/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.6.ebuild
new file mode 100644
index 000000000000..16b7250b0083
--- /dev/null
+++ b/app-portage/pkg-testing-tools/pkg-testing-tools-0.2.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Packages testing tools for Gentoo"
+HOMEPAGE="https://github.com/APN-Pucky/pkg-testing-tools"
+
+REPO=APN-Pucky
+LICENSE="BSD"
+SLOT="0"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${REPO}/${PN}"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+ SRC_URI="https://github.com/${REPO}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+fi
+
+IUSE="test"
+RESTRICT="!test? ( test )"
+RDEPEND="
+ sys-apps/portage[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild b/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild
index c8cd079994a1..16b7250b0083 100644
--- a/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild
+++ b/app-portage/pkg-testing-tools/pkg-testing-tools-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -20,7 +20,7 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/${REPO}/${PN}"
else
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
- SRC_URI="https://github.com/APN-Pucky/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ SRC_URI="https://github.com/${REPO}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
fi
IUSE="test"