summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-07-07 14:53:20 +0200
committerConrad Kostecki <conikost@gentoo.org>2023-07-07 23:52:58 +0200
commit45c1a2a891b4099d38a76368ee52d1bea080b113 (patch)
treeb5be7f89a4e0eef45f4618bd5028b1f4a6460578 /app-shells
parentsys-apps/busybox: Stabilize 1.36.1 arm64, #909748 (diff)
downloadgentoo-45c1a2a891b4099d38a76368ee52d1bea080b113.tar.gz
gentoo-45c1a2a891b4099d38a76368ee52d1bea080b113.tar.bz2
gentoo-45c1a2a891b4099d38a76368ee52d1bea080b113.zip
app-shells/ccsh: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/31789 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ccsh/ccsh-0.0.4-r5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-shells/ccsh/ccsh-0.0.4-r5.ebuild b/app-shells/ccsh/ccsh-0.0.4-r5.ebuild
new file mode 100644
index 000000000000..c8b2106df52f
--- /dev/null
+++ b/app-shells/ccsh/ccsh-0.0.4-r5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="UNIX Shell for people already familiar with the C language"
+HOMEPAGE="https://ccsh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ccsh/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ exeinto /bin
+ doexe "${PN}"
+ newman "${PN}.man" "${PN}.1"
+ dodoc ChangeLog README TODO
+}