summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-27 22:00:56 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-27 22:52:35 +0100
commit5c90cd64744d8effee2a0d66b7a3837804e65c48 (patch)
tree8044c46ee2465c74bab54c977dc7a57a0e61881f /app-shells
parentnet-libs/webkit-gtk: enable ruby33 (diff)
downloadgentoo-5c90cd64744d8effee2a0d66b7a3837804e65c48.tar.gz
gentoo-5c90cd64744d8effee2a0d66b7a3837804e65c48.tar.bz2
gentoo-5c90cd64744d8effee2a0d66b7a3837804e65c48.zip
app-shells/invokebuild: new package; add 5.10.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/invokebuild/Manifest1
-rw-r--r--app-shells/invokebuild/invokebuild-5.10.5.ebuild32
-rw-r--r--app-shells/invokebuild/metadata.xml13
3 files changed, 46 insertions, 0 deletions
diff --git a/app-shells/invokebuild/Manifest b/app-shells/invokebuild/Manifest
new file mode 100644
index 000000000000..43a3dcc0c0c6
--- /dev/null
+++ b/app-shells/invokebuild/Manifest
@@ -0,0 +1 @@
+DIST invokebuild-5.10.5.zip 40940 BLAKE2B d67d7b9e1a90af8b898558910bc766a7f4e186abbb678f50940f5783c028d0ca16ec77e394dc486c3553b03016581ce73b6f73f9f68271bad53cfafdb7f39de3 SHA512 4210a31885f6d6126b70aa6f2c8bbf41d62e404c65637f9d5aa7daa8cb8a9e052595ebd28b7b2794a7107c01193fa02cd3f6a8c8c456f2ce2d0f8e13adfc7668
diff --git a/app-shells/invokebuild/invokebuild-5.10.5.ebuild b/app-shells/invokebuild/invokebuild-5.10.5.ebuild
new file mode 100644
index 000000000000..583ef0ac859b
--- /dev/null
+++ b/app-shells/invokebuild/invokebuild-5.10.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Build and test automation in PowerShell"
+HOMEPAGE="https://github.com/nightroman/Invoke-Build/"
+SRC_URI="https://www.powershellgallery.com/api/v2/package/${PN}/${PV}
+ -> ${P}.zip"
+S="${WORKDIR}"
+
+LICENSE="Apache-2.0"
+SLOT="${PV}"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ virtual/pwsh:*
+"
+BDEPEND="
+ app-arch/unzip
+"
+
+src_prepare() {
+ default
+
+ rm -f -r '[Content_Types].xml' _rels package || die
+}
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/InvokeBuild/${PV}"
+ doins -r .
+}
diff --git a/app-shells/invokebuild/metadata.xml b/app-shells/invokebuild/metadata.xml
new file mode 100644
index 000000000000..463c3cf6a20b
--- /dev/null
+++ b/app-shells/invokebuild/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>dotnet@gentoo.org</email>
+ <name>Gentoo Dotnet Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://gitlab.com/nightroman/Invoke-Build/issues/</bugs-to>
+ <remote-id type="github">nightroman/Invoke-Build</remote-id>
+ </upstream>
+</pkgmetadata>