summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2016-12-21 22:25:03 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2017-01-04 23:37:09 +0100
commit135c336181466c6f86437a5a8b4b40a523a6b12b (patch)
treeff3d2e0cf27a13b0800053cd287d3d72dc495b0a /app-text/gspell/gspell-1.2.2.ebuild
parentdev-util/meld: bump to 3.16.4 (diff)
downloadgentoo-135c336181466c6f86437a5a8b4b40a523a6b12b.tar.gz
gentoo-135c336181466c6f86437a5a8b4b40a523a6b12b.tar.bz2
gentoo-135c336181466c6f86437a5a8b4b40a523a6b12b.zip
app-text/gspell: bump to 1.2.2
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3208 Signed-off-by: Gilles Dartiguelongue <eva@gentoo.org>
Diffstat (limited to 'app-text/gspell/gspell-1.2.2.ebuild')
-rw-r--r--app-text/gspell/gspell-1.2.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-text/gspell/gspell-1.2.2.ebuild b/app-text/gspell/gspell-1.2.2.ebuild
new file mode 100644
index 000000000000..5e42ce02f92f
--- /dev/null
+++ b/app-text/gspell/gspell-1.2.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~x86"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ app-text/iso-codes
+ >=app-text/enchant-1.6.0
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.25
+ >=dev-util/intltool-0.35.0
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}