summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2024-11-28 19:02:42 +0700
committerAndrey Grozin <grozin@gentoo.org>2024-11-28 19:02:42 +0700
commit26f7383f432c124b7b193cdd8f112fb85db18a8a (patch)
tree58cde5d83817e604261a337dd0e8813215bc18e6 /app-text/master-pdf-editor
parentapp-backup/borgmatic: drop 1.9.0, 1.9.1 (diff)
downloadgentoo-26f7383f432c124b7b193cdd8f112fb85db18a8a.tar.gz
gentoo-26f7383f432c124b7b193cdd8f112fb85db18a8a.tar.bz2
gentoo-26f7383f432c124b7b193cdd8f112fb85db18a8a.zip
app-text/master-pdf-editor: add missing dependencies
Closes: https://bugs.gentoo.org/944414 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text/master-pdf-editor')
-rw-r--r--app-text/master-pdf-editor/master-pdf-editor-5.9.86-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-text/master-pdf-editor/master-pdf-editor-5.9.86-r1.ebuild b/app-text/master-pdf-editor/master-pdf-editor-5.9.86-r1.ebuild
new file mode 100644
index 000000000000..a72f8ce95f1e
--- /dev/null
+++ b/app-text/master-pdf-editor/master-pdf-editor-5.9.86-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop xdg
+
+DESCRIPTION="A complete solution for viewing and editing PDF files"
+HOMEPAGE="https://code-industry.net/free-pdf-editor/"
+SRC_URI="https://code-industry.net/public/${P}-qt5.x86_64-qt_include.tar.gz"
+S="${WORKDIR}/${PN}-${PV%%.*}"
+
+LICENSE="master-pdf-editor"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="mirror"
+
+RDEPEND="
+ dev-libs/pkcs11-helper
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-libs/freetype
+ media-libs/libglvnd
+ media-gfx/sane-backends
+ sys-libs/glibc
+ sys-libs/zlib
+"
+
+QA_PREBUILT="opt/${PN}/masterpdfeditor5"
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r fonts help iconengines imageformats lang platforms platformthemes stamps templates masterpdfeditor5.png
+ exeinto /opt/${PN}
+ doexe masterpdfeditor5 masterpdfeditor5.sh
+ exeinto /opt/bin
+ doexe "${FILESDIR}"/mpe5
+
+ make_desktop_entry "mpe5 %f" \
+ "Master PDF Editor ${PV}" /opt/${PN}/masterpdfeditor5.png \
+ "Office;Graphics;Viewer" \
+ "MimeType=application/pdf;application/x-bzpdf;application/x-gzpdf;\nTerminal=false"
+}