summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-04 13:09:12 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-04 13:09:12 +0200
commit7cd9f9e7a598919b3dfc29385d7a54c7b706ee0c (patch)
tree3218d34407e10c7ae8c663917f56b206d3bc8085 /app-text/pandoc-bin
parentapp-emacs/racket-mode: drop old 20220219-r1 (diff)
downloadgentoo-7cd9f9e7a598919b3dfc29385d7a54c7b706ee0c.tar.gz
gentoo-7cd9f9e7a598919b3dfc29385d7a54c7b706ee0c.tar.bz2
gentoo-7cd9f9e7a598919b3dfc29385d7a54c7b706ee0c.zip
app-text/pandoc-bin: bump to 2.19
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-text/pandoc-bin')
-rw-r--r--app-text/pandoc-bin/Manifest2
-rw-r--r--app-text/pandoc-bin/pandoc-bin-2.19.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/pandoc-bin/Manifest b/app-text/pandoc-bin/Manifest
index 714fa4e90606..96d2e3aa85cb 100644
--- a/app-text/pandoc-bin/Manifest
+++ b/app-text/pandoc-bin/Manifest
@@ -1,2 +1,4 @@
DIST pandoc-2.18-linux-amd64.tar.gz 16713899 BLAKE2B 89f2166fb93793c07af9d3ddff56767e4072500b80cd462a498f5534fdbfba974fa517fa05c3bfeaf44179cd23b6d53fc5daed5916f18fce13df4486040610ca SHA512 ec0285e9a1640e7594d5bdca3fcdc738b2139e20f4a4f75b0f49ff76d2d2f5a0e8b90912e63a93e787c57f18eb3d155f214f088e55b435ef03acb8cfbf92272b
DIST pandoc-2.18-linux-arm64.tar.gz 18522530 BLAKE2B 84e2479a77c12ace90a93ed9b66be2abdec357e0b4338143db8a9318cd48e76852d9fc12ceb8bd795860412a2e98d11a4d1e54bf74bdf68494c699fd5878c818 SHA512 e2be1473edeba12996a9eb7af3fe7dfd860adb1054446d2b93db6d712708282424628b14fea8809dba903e93daa1626a0dc3e1304af33b77e9da298c8fd7885b
+DIST pandoc-2.19-linux-amd64.tar.gz 16807538 BLAKE2B f92ca873d3f048768ecf39533c60157db59ed3c0b1849b7bfe8093f1590a076bd36f3fda81800527d1ec03b2387564e4bd37e35fd991a356d3caa33afb3de30a SHA512 8ad0b0a790681d2665866d8ecd6b04a5b0944e88ff6c202e4b44c0dc0ad27f45ab24136641dbcb03e10953fcaa833020125b0e08f12e3a18e014dab32934f67e
+DIST pandoc-2.19-linux-arm64.tar.gz 18631015 BLAKE2B 5e4ca9f33a10dd98c3e95798f073d2527d6aebe8a12af2d24fb93346a5ef5c6e567d3fb1b26a222a4f252efc77d874233ad4eb0c26a2b7185b4593541235d583 SHA512 f16c8114e2551203e603285f4ab27a1343516acaad622b672d617ce15b3fb108fe4e9a5926ba1d70545bdba8822291a94f4b65ff228a89bf7262286c80eb887c
diff --git a/app-text/pandoc-bin/pandoc-bin-2.19.ebuild b/app-text/pandoc-bin/pandoc-bin-2.19.ebuild
new file mode 100644
index 000000000000..13a2ca157762
--- /dev/null
+++ b/app-text/pandoc-bin/pandoc-bin-2.19.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN//-bin/}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Conversion between markup formats (binary package)"
+HOMEPAGE="https://pandoc.org/"
+
+BASE_URI="https://github.com/jgm/${MY_PN}/releases/download/${PV}/${MY_P}"
+SRC_URI="
+ amd64? ( ${BASE_URI}-linux-amd64.tar.gz )
+ arm64? ( ${BASE_URI}-linux-arm64.tar.gz )
+"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64" # Upstream provides only AMD and ARM 64-bit binaries
+IUSE="+pandoc-symlink"
+
+RDEPEND="pandoc-symlink? ( !${CATEGORY}/${MY_PN} )"
+
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+QA_PRESTRIPPED="${QA_FLAGS_IGNORED}"
+
+src_unpack() {
+ default
+
+ # Manpages are gzipped
+ unpack "${S}"/share/man/man1/${MY_PN}.1.gz
+}
+
+src_install() {
+ newbin bin/${MY_PN} ${PN}
+ newman "${WORKDIR}"/${MY_PN}.1 ${PN}.1
+
+ if use pandoc-symlink ; then
+ dosym ${PN} /usr/bin/${MY_PN}
+ dosym ${PN}.1 /usr/share/man/man1/${MY_PN}.1
+ fi
+}