summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOskari Pirhonen <xxc3ncoredxx@gmail.com>2024-03-12 22:23:39 -0500
committerSam James <sam@gentoo.org>2024-03-13 04:02:14 +0000
commitff592f720f3dbb70f85765145cd48a0e68072f69 (patch)
tree51ac0fec56e5a223e19ae80e5ff73e9a44099106 /app-text/wgetpaste
parentdev-libs/libx86: fix modern C issue (diff)
downloadgentoo-ff592f720f3dbb70f85765145cd48a0e68072f69.tar.gz
gentoo-ff592f720f3dbb70f85765145cd48a0e68072f69.tar.bz2
gentoo-ff592f720f3dbb70f85765145cd48a0e68072f69.zip
app-text/wgetpaste: add 2.34
Signed-off-by: Oskari Pirhonen <xxc3ncoredxx@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35734 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/wgetpaste')
-rw-r--r--app-text/wgetpaste/Manifest1
-rw-r--r--app-text/wgetpaste/wgetpaste-2.34.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-text/wgetpaste/Manifest b/app-text/wgetpaste/Manifest
index 1d552853b25f..e957693da79a 100644
--- a/app-text/wgetpaste/Manifest
+++ b/app-text/wgetpaste/Manifest
@@ -1 +1,2 @@
DIST wgetpaste-2.33.tar.xz 16408 BLAKE2B 78baebf4edb6e6340a73127099366d306359d02c0c1eab137822c56669da0609a5479940b4fb2accbc79978df091dcd34415876618e64aa556d1584f74773736 SHA512 9bf1f379316da372b4f69296b54f9a266dcf9fdaa2a8718165a2029571f4c2c0166304ffebeb2ec4657ea6f49087793f40d9da383f5da052bce0543c90ea13ab
+DIST wgetpaste-2.34.tar.xz 16640 BLAKE2B 6bc71d74945b88774f866a8c1bb693d52b3d5d680a04e45ec29acfb6dd9d9de16433ed9d675db1d63705dac356e44c89d7af0e7b18a71089778bfa92833d95d3 SHA512 9f334299d0314e821d989c785aaae9e8e9c0e4972ced9330039f7e2ca1867528a2d4f090dd754ec72e8a9d7005d8f5154266cd0769627b1023d1199893cf4f8c
diff --git a/app-text/wgetpaste/wgetpaste-2.34.ebuild b/app-text/wgetpaste/wgetpaste-2.34.ebuild
new file mode 100644
index 000000000000..9eb248cf9574
--- /dev/null
+++ b/app-text/wgetpaste/wgetpaste-2.34.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Command-line interface to various pastebins"
+HOMEPAGE="https://github.com/zlin/wgetpaste"
+SRC_URI="https://github.com/zlin/wgetpaste/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+ssl"
+
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="net-misc/wget[ssl?]"
+
+src_prepare() {
+ default
+
+ sed -i -e "s:/etc:\"${EPREFIX}\"/etc:g" wgetpaste || die
+}
+
+src_test() {
+ test/test.sh || die
+}
+
+src_install() {
+ dobin ${PN}
+ insinto /usr/share/zsh/site-functions
+ doins _wgetpaste
+}
+
+pkg_postinst() {
+ optfeature "ANSI (color code) stripping support" app-text/ansifilter
+ optfeature "xclip support" x11-misc/xclip
+
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ if ver_test ${old} -lt '2.33-r2'; then
+ ewarn
+ ewarn "Sprunge is dead and the service has been dropped from the code. Remove or"
+ ewarn "replace sprunge as the default service in the system or user wgetpaste"
+ ewarn "config if applicable."
+ ewarn
+ break
+ fi
+ done
+ fi
+}