summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2022-01-16 20:35:12 -0500
committerAnthony G. Basile <blueness@gentoo.org>2022-01-16 20:35:22 -0500
commit937dc3b6ac871f27c700150156fcec359e8e8fdf (patch)
tree85d3f9b391286439be86f37e9cae04cf022c7d49 /app-text/xapian-omega
parentdev-libs/expat: Stabilize 2.4.3 sparc, #831326 (diff)
downloadgentoo-937dc3b6ac871f27c700150156fcec359e8e8fdf.tar.gz
gentoo-937dc3b6ac871f27c700150156fcec359e8e8fdf.tar.bz2
gentoo-937dc3b6ac871f27c700150156fcec359e8e8fdf.zip
app-text/xapian-omega: version bump to 1.4.19
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'app-text/xapian-omega')
-rw-r--r--app-text/xapian-omega/Manifest1
-rw-r--r--app-text/xapian-omega/xapian-omega-1.4.19.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-text/xapian-omega/Manifest b/app-text/xapian-omega/Manifest
index e55f75c3864f..e7afb8c83af6 100644
--- a/app-text/xapian-omega/Manifest
+++ b/app-text/xapian-omega/Manifest
@@ -3,3 +3,4 @@ DIST xapian-omega-1.4.15.tar.xz 545916 BLAKE2B be89c817d13888bc8de28973be15a5129
DIST xapian-omega-1.4.16.tar.xz 546360 BLAKE2B 990eab976833854d2a172e1584383b71375fe2e0b83a8ff0a150f4c9fdb6e99cbd42e58720e81698292843918112426d3b445efe14d9ee5f76e85304439475de SHA512 7f8c3d4e372c49f89e28da999ee49f0754052a339bbc4492b50f8134cf29b2c433ddae9e58ef3a2468898b711b4510ea87687a247ce21e83eba2f8daaa2910c4
DIST xapian-omega-1.4.17.tar.xz 547372 BLAKE2B d164ee2f96d395e2a45919aea821d1bae9b028b64389b4a6e6f1179c0e1c2a92983a3fe7a71f68fe11e04eb61e9f011c21f2edf5660f9feedccd41de8ed2f445 SHA512 0388714ae307044b486e92eacac2d8c09c334e1b77be6cc2c36f8c0c679b4fee660c9b12074e9a278e2981b4a5b4a607d068a5d16c852bef719245bb70b7ce7c
DIST xapian-omega-1.4.18.tar.xz 549892 BLAKE2B 440f7ac93acca5803c80d905a90db854f36a5fb1e486d5178c25db0490bc01812f2173feb8abb97a2e399449950524db7b557b303c671d1e9a50f062f332008a SHA512 35da36bdaa6997353554604db5ced3f3a05d0862ce5cf357fae639ca88a65ea83bf0be039629e6aedd67f8cb369a7eaeba7f279980c9e2f585083c737c61ea43
+DIST xapian-omega-1.4.19.tar.xz 553680 BLAKE2B 1008376d2ba6d72d3cc267ee3bda78a1d37491d706417010e0f4ca7dddf78ddd3d9ad07108874eabfffd0280016ce1fad49c86ee89eed9b37ae571586f838c9b SHA512 82b682bc9d244256afffc2ab1b12b0f577184296a979dc42b2865b689c6d46eca6b838b95a5d040dc228de0c2e2261e81279e0a748eaff2d018732ce4bc07fae
diff --git a/app-text/xapian-omega/xapian-omega-1.4.19.ebuild b/app-text/xapian-omega/xapian-omega-1.4.19.ebuild
new file mode 100644
index 000000000000..8095ec6dba1f
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.4.19.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
+HOMEPAGE="https://xapian.org/"
+S="${WORKDIR}/xapian-omega-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="~dev-libs/xapian-1.4.19:0/30
+ dev-lang/perl
+ dev-libs/libpcre
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${D}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}