summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2024-10-28 17:02:11 +0000
committerPatrick Lauer <patrick@gentoo.org>2024-10-28 17:03:23 +0000
commit2687f0e7a1aaa340f3106ee6b51e8c0875d9a083 (patch)
tree128f2cfe69ca9b82c4273471b94b4d4901803ab7 /app-text
parentdev-python/rdflib: Bump to 7.1.1 (diff)
downloadgentoo-2687f0e7a1aaa340f3106ee6b51e8c0875d9a083.tar.gz
gentoo-2687f0e7a1aaa340f3106ee6b51e8c0875d9a083.tar.bz2
gentoo-2687f0e7a1aaa340f3106ee6b51e8c0875d9a083.zip
app-text/groonga: add 14.0.9
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/groonga/Manifest1
-rw-r--r--app-text/groonga/groonga-14.0.9.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/app-text/groonga/Manifest b/app-text/groonga/Manifest
index 66ef54edf5ae..0a653c5bbe1a 100644
--- a/app-text/groonga/Manifest
+++ b/app-text/groonga/Manifest
@@ -1,3 +1,4 @@
DIST groonga-13.0.1.tar.gz 24694524 BLAKE2B 326ca810bdf4634b778eb6efc7a6c56626b0c5b563d9b896da23a103399e51ca57e8d1dd87aa05dbbe527f67cb6875924ca073f007698f5077437e2b191b995a SHA512 54eda0c70f932f249dbf58f01367d9a05a9d8e6e9a1df92e0a9070f452596cfc38da59b02c5128a585f9e19d460ce8100dd2677aaba7049e129a963491b22362
DIST groonga-14.0.4.tar.gz 48878675 BLAKE2B 9918331dbc043f3e89ec0be83de1587cf801f55fac6047f65ab825678b501ef2cd4ba230a73ab98bc879603f3f8aab053b1ca91de960e1a6f209796bc114ee93 SHA512 4aaeaaad801bf10626643434dc1eaacc86452876fcd33b0ad4e2e3c6d032ab5bfdf9fae108ce06bd93f7a94b8b2895a4ad5d38aaec4d8cdc52ec7ff96dfccff4
+DIST groonga-14.0.9.tar.gz 51609936 BLAKE2B a6e13ad780475d59b5b7b53fc1e9b74512afd91bc7b9b620ec1d8a4e46c46b5d9f14394cba68c1e394dd558708245536e2981d462dcf31e8e00e9cd50ad997e6 SHA512 58535c057b0dee0b8c92ff313968d83d6b82eb802b9fe5153c9f7b00a70e5419735873e3c0aeb61f82baf81f16d117198adf52dd7a6cf6de9d936b140f04727e
DIST groonga-8.0.2.tar.gz 15095427 BLAKE2B fa83034a434edaa35dede08cb042e48f15e1e2edd78a121f9341f53f53a5eef863d02e2ea6384428c720c4ff9acf1083504046c8c11a1ea8d7bfc4b541db66b5 SHA512 bc5590604054c4adfbc80b39c7cf367e8a989c47d80c37c48feffb9a427b4b4e360289f3d732f6affa7d26a1c8559f23bda1c70b6736a06601398fce9a53acf1
diff --git a/app-text/groonga/groonga-14.0.9.ebuild b/app-text/groonga/groonga-14.0.9.ebuild
new file mode 100644
index 000000000000..670474842073
--- /dev/null
+++ b/app-text/groonga/groonga-14.0.9.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit libtool
+
+DESCRIPTION="An Embeddable Fulltext Search Engine"
+HOMEPAGE="https://groonga.org/"
+SRC_URI="https://packages.groonga.org/source/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="benchmark debug doc +exact-alloc-count examples futex jemalloc libedit libevent lzo +mecab msgpack +nfkc sphinx static-libs uyield zeromq zlib zstd"
+REQUIRED_USE="
+ sphinx? ( doc )
+"
+
+DEPEND="
+ acct-group/groonga
+ acct-user/groonga
+ >=dev-libs/onigmo-6.1.1:0=
+ dev-libs/rapidjson
+ dev-libs/xxhash
+ benchmark? ( >=dev-libs/glib-2.8 )
+ jemalloc? ( dev-libs/jemalloc:0= )
+ libedit? ( >=dev-libs/libedit-3 )
+ libevent? ( dev-libs/libevent:0= )
+ lzo? ( dev-libs/lzo )
+ mecab? ( >=app-text/mecab-0.80 )
+ msgpack? ( dev-libs/msgpack:= )
+ sphinx? ( >=dev-python/sphinx-1.0.1 )
+ zeromq? ( net-libs/zeromq:0= )
+ zlib? ( sys-libs/zlib:0= )
+ zstd? ( app-arch/zstd:0= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ sphinx? ( dev-python/sphinx )
+"
+
+src_prepare() {
+ default
+
+ elibtoolize
+}
+
+src_configure() {
+ # httpd is a bundled copy of nginx; disabled for security reasons
+ # prce only is used with httpd
+ # Apache arrow, kytea and libstemmer are not available in Gentoo repo
+ # ruby is only used for an http test
+ local econfopts=(
+ --disable-groonga-httpd
+ --without-pcre
+ --without-kytea
+ --without-libstemmer
+ --disable-arrow
+ --with-log-path="${EPREFIX}"/var/log/${PN}.log
+ --without-luajit
+ --without-ruby
+ --with-shared-onigmo
+ --with-onigmo=system
+ --with-xxhash
+ $(use_enable benchmark)
+ $(use_enable debug memory-debug)
+ $(use_enable doc document)
+ $(use_enable exact-alloc-count)
+ $(use_enable futex)
+ $(use_with jemalloc)
+ $(use_enable libedit)
+ $(use_with libevent)
+ $(use_with lzo)
+ $(use_with mecab)
+ $(use_enable msgpack message-pack)
+ $(use_with msgpack message-pack "${ESYSROOT}/usr")
+ $(use_enable nfkc)
+ $(use_with sphinx sphinx-build)
+ $(use_enable static-libs static)
+ $(use_enable uyield)
+ $(use_enable zeromq)
+ $(use_with zlib)
+ $(use_with zstd)
+ )
+
+ econf "${econfopts[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ keepdir /var/{log,lib}/${PN}
+ fowners groonga:groonga /var/{log,lib}/${PN}
+
+ if ! use examples ; then
+ rm -r "${ED}/usr/share/${PN}" || die
+ fi
+}