summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-09-18 19:17:55 +0000
committerSam James <sam@gentoo.org>2024-11-19 14:20:49 +0000
commitcca2ef8c921f83bf05df99eda2196c6305c12087 (patch)
tree3a6749ad5b35a92ee64a5f74b3a051d69ee77959 /app-text
parentprofiles/features/musl: mask sys-apps/dog (diff)
downloadgentoo-cca2ef8c921f83bf05df99eda2196c6305c12087.tar.gz
gentoo-cca2ef8c921f83bf05df99eda2196c6305c12087.tar.bz2
gentoo-cca2ef8c921f83bf05df99eda2196c6305c12087.zip
app-text/unrtf: Fix call to undeclared function strcasestr
and update EAPI 7 -> 8 [sam: Tweak comment and rename patch file to reflect the version that was finally submitted rather than the initial version.] Closes: https://bugs.gentoo.org/894716 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32868 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/unrtf/files/unrtf-0.21.10-use-_GNU_SOURCE.patch11
-rw-r--r--app-text/unrtf/unrtf-0.21.10-r1.ebuild24
2 files changed, 35 insertions, 0 deletions
diff --git a/app-text/unrtf/files/unrtf-0.21.10-use-_GNU_SOURCE.patch b/app-text/unrtf/files/unrtf-0.21.10-use-_GNU_SOURCE.patch
new file mode 100644
index 000000000000..7aaaef65e27a
--- /dev/null
+++ b/app-text/unrtf/files/unrtf-0.21.10-use-_GNU_SOURCE.patch
@@ -0,0 +1,11 @@
+Bug: https://bugs.gentoo.org/894716
+--- a/src/convert.c
++++ b/src/convert.c
+@@ -104,6 +104,7 @@
+ #ifdef HAVE_STRING_H
+ /* For strcasestr() */
+ #define __USE_GNU
++#define _GNU_SOURCE
+ #include <string.h>
+ #endif
+
diff --git a/app-text/unrtf/unrtf-0.21.10-r1.ebuild b/app-text/unrtf/unrtf-0.21.10-r1.ebuild
new file mode 100644
index 000000000000..9734ade2ec5c
--- /dev/null
+++ b/app-text/unrtf/unrtf-0.21.10-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Converts RTF files to various formats"
+HOMEPAGE="https://www.gnu.org/software/unrtf/unrtf.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.21.10-use-_GNU_SOURCE.patch
+)
+
+src_configure() {
+ append-flags -std=gnu17
+
+ econf
+}