summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-13 21:18:23 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-14 20:23:14 +0100
commite18842a9aabd9a2ab876a19944a4773affdb4e25 (patch)
tree80094c4adb7eee0bf67a85f01fe52b04b0a20d3a /dev-build/tinycmmc
parentMove {dev-util → dev-build}/rocm-cmake (diff)
downloadgentoo-e18842a9aabd9a2ab876a19944a4773affdb4e25.tar.gz
gentoo-e18842a9aabd9a2ab876a19944a4773affdb4e25.tar.bz2
gentoo-e18842a9aabd9a2ab876a19944a4773affdb4e25.zip
Move {dev-util → dev-build}/tinycmmc
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-build/tinycmmc')
-rw-r--r--dev-build/tinycmmc/Manifest1
-rw-r--r--dev-build/tinycmmc/metadata.xml15
-rw-r--r--dev-build/tinycmmc/tinycmmc-0.1.0.ebuild20
-rw-r--r--dev-build/tinycmmc/tinycmmc-9999.ebuild20
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-build/tinycmmc/Manifest b/dev-build/tinycmmc/Manifest
new file mode 100644
index 000000000000..4b84d407313d
--- /dev/null
+++ b/dev-build/tinycmmc/Manifest
@@ -0,0 +1 @@
+DIST tinycmmc-0.1.0.tar.gz 10559 BLAKE2B 9708c6c95c5746d000bb02b46bc40b788b8b18d55d3bd2e97e88789f4b084e145db39e038b4d619c75273b8fd23713f6906a8618fa248664a468c60e1073000c SHA512 cf1e8108be2f5c8a23e08756b6f50a2493a688ffa8bd7a06a59330cdd74046035705f18d5f53a00d6779dafb76a2c529b4ca9be7e53ff2660d718e8f68544769
diff --git a/dev-build/tinycmmc/metadata.xml b/dev-build/tinycmmc/metadata.xml
new file mode 100644
index 000000000000..a85353b5969e
--- /dev/null
+++ b/dev-build/tinycmmc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>orbea@riseup.net</email>
+ <name>orbea</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Grumbel/tinycmmc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-build/tinycmmc/tinycmmc-0.1.0.ebuild b/dev-build/tinycmmc/tinycmmc-0.1.0.ebuild
new file mode 100644
index 000000000000..88aaf86e9ab9
--- /dev/null
+++ b/dev-build/tinycmmc/tinycmmc-0.1.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Grumbel/${PN}.git"
+else
+ SRC_URI="https://github.com/Grumbel/${PN}/archive/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Tiny CMake Module Collections"
+HOMEPAGE="https://github.com/Grumbel/tinycmmc"
+
+LICENSE="GPL-3+"
+SLOT="0"
diff --git a/dev-build/tinycmmc/tinycmmc-9999.ebuild b/dev-build/tinycmmc/tinycmmc-9999.ebuild
new file mode 100644
index 000000000000..8bbe616423ad
--- /dev/null
+++ b/dev-build/tinycmmc/tinycmmc-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Grumbel/${PN}.git"
+else
+ SRC_URI="https://github.com/Grumbel/${PN}/archive/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Tiny CMake Module Collections"
+HOMEPAGE="https://github.com/Grumbel/tinycmmc"
+
+LICENSE="ZLIB"
+SLOT="0"