summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornick black <dankamongmen@gmail.com>2021-02-10 05:23:57 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-03-21 10:06:40 +0200
commitcabc623be4ee53b9e0a58018c87de83ededaa097 (patch)
tree3b9513272f463a8e13b27cc3f069c10006fd854c /dev-cpp/notcurses
parentdev-python/humanize: Bump to 3.3.0 (diff)
downloadgentoo-cabc623be4ee53b9e0a58018c87de83ededaa097.tar.gz
gentoo-cabc623be4ee53b9e0a58018c87de83ededaa097.tar.bz2
gentoo-cabc623be4ee53b9e0a58018c87de83ededaa097.zip
dev-cpp/notcurses: initial ebuild 2.2.3
Notcurses is a library for creating blingful TUIs and terminal graphics. It supports 8bpc RGB color, Unicode, pixel graphics using Sixel or the Kitty protocol, and sane multithreading. Signed-off-by: nick black <dankamongmen@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19402 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-cpp/notcurses')
-rw-r--r--dev-cpp/notcurses/Manifest2
-rw-r--r--dev-cpp/notcurses/metadata.xml22
-rw-r--r--dev-cpp/notcurses/notcurses-2.2.3.ebuild51
3 files changed, 75 insertions, 0 deletions
diff --git a/dev-cpp/notcurses/Manifest b/dev-cpp/notcurses/Manifest
new file mode 100644
index 000000000000..44dc9a74987b
--- /dev/null
+++ b/dev-cpp/notcurses/Manifest
@@ -0,0 +1,2 @@
+DIST notcurses-2.2.3.tar.gz 10861361 BLAKE2B e7b487e84b5defbb1208f355c85f7178b05f412c2a746a8bcecb2da7db8df32da563aeb1f1f218014a2ff9803f0984889e4341d59f585add49c944d4707e5cd4 SHA512 9c718a39352cc10e4f4cb24cd7940ccc7ac7ad1f5890f1a87166267b3c24011629464a4720f08c2b8bbf0fab2c5cb9b31fba7a43bc62ae65dff894019adece7d
+DIST notcurses-doc-2.2.3.tar.gz 89550 BLAKE2B a42c74f95166e48ecff99a05d66925869a44a44c4faa867cca663d94ee340748417d6560d022fdb90c7761c19285b0c4838b75843a3d26d25182977f68a0d6ce SHA512 b61f829d1ad5f69147a7b4fe139db406d5a26683b55d72251f3e313c17f591ad4e9e868577fbecf86c4ac9959c942e244927fb29a2e44996fadde7946493ccc8
diff --git a/dev-cpp/notcurses/metadata.xml b/dev-cpp/notcurses/metadata.xml
new file mode 100644
index 000000000000..3fe0567d3e8b
--- /dev/null
+++ b/dev-cpp/notcurses/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dankamongmen@gmail.com</email>
+ <name>nick black</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Notcurses facilitates the creation of modern TUI programs,
+ making full use of Unicode and 24-bit TrueColor. It presents
+ an API similar to that of Curses, and rides atop Terminfo.
+ </longdescription>
+ <longdescription lang="es">
+ Notcurses facilita la creación de programas TUI actuales,
+ haciendo un uso completo de Unicode y color real de 24 bits.
+ Presenta una API similar a la de Curses y funciona sobre Terminfo.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-cpp/notcurses/notcurses-2.2.3.ebuild b/dev-cpp/notcurses/notcurses-2.2.3.ebuild
new file mode 100644
index 000000000000..e605c199a795
--- /dev/null
+++ b/dev-cpp/notcurses/notcurses-2.2.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS="cmake"
+inherit cmake-multilib
+
+DESCRIPTION="Blingful TUIs and character graphics"
+HOMEPAGE="https://notcurses.com"
+SRC_URI="https://github.com/dankamongmen/notcurses/archive/v${PV}.tar.gz -> ${P}.tar.gz doc? ( https://github.com/dankamongmen/notcurses/releases/download/v${PV}/notcurses-doc-${PV}.tar.gz )"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+doc"
+
+DEPEND="dev-libs/libunistring
+ media-video/ffmpeg
+ >=sys-libs/readline-8.0"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_DOCTEST=OFF
+ -DUSE_MULTIMEDIA=ffmpeg
+ -DUSE_PANDOC=OFF
+ -DUSE_QRCODEGEN=OFF
+ -DUSE_STATIC=OFF
+ )
+ cmake-multilib_src_configure
+}
+
+src_compile() {
+ cmake-multilib_src_compile
+}
+
+src_test() {
+ multilib_src_test
+}
+
+src_install() {
+ cmake-multilib_src_install
+ if use doc ; then
+ # we use this tortured form lest we try, every time we release a
+ # x.y.1 or x.y.3, to install the source dir as a man page.
+ # exploit the fact that there's a bijection from html<>man.
+ for i in ../*.html ; do
+ doman ../$(basename $i .html)
+ done
+ fi
+}