summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2024-08-30 17:25:33 +0200
committerJakov Smolić <jsmolic@gentoo.org>2024-08-30 17:25:33 +0200
commit64ef77217033e11b4fc3bc873a02ba16ea161d1f (patch)
tree6eef9055e4bd505790d6de72571e72569f9f8a43 /dev-cpp
parentdev-embedded/avra: update EAPI 7 -> 8 (diff)
downloadgentoo-64ef77217033e11b4fc3bc873a02ba16ea161d1f.tar.gz
gentoo-64ef77217033e11b4fc3bc873a02ba16ea161d1f.tar.bz2
gentoo-64ef77217033e11b4fc3bc873a02ba16ea161d1f.zip
dev-cpp/sparsehash: update EAPI 7 -> 8
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/sparsehash/sparsehash-2.0.4-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-cpp/sparsehash/sparsehash-2.0.4-r1.ebuild b/dev-cpp/sparsehash/sparsehash-2.0.4-r1.ebuild
new file mode 100644
index 000000000000..4fa97720bb96
--- /dev/null
+++ b/dev-cpp/sparsehash/sparsehash-2.0.4-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
+HOMEPAGE="https://github.com/sparsehash/sparsehash"
+SRC_URI="https://github.com/sparsehash/sparsehash/archive/${P}.tar.gz"
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.3-fix-buildsystem.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}