summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2024-08-15 22:05:59 -0400
committerNick Sarnie <sarnex@gentoo.org>2024-08-15 22:08:04 -0400
commit8f532e79627b5ded47979f9d9707d49ab306fab0 (patch)
tree24dc8ea5ad2dcec6163cc92f763dbc4f86883254 /dev-cpp
parentdev-build/meson: drop old (diff)
downloadgentoo-8f532e79627b5ded47979f9d9707d49ab306fab0.tar.gz
gentoo-8f532e79627b5ded47979f9d9707d49ab306fab0.tar.bz2
gentoo-8f532e79627b5ded47979f9d9707d49ab306fab0.zip
dev-cpp/robin-hood-hashing: Fix build with gcc-15
Closes: https://bugs.gentoo.org/937693 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/robin-hood-hashing/files/robin-hood-hashing-include-cstdint.patch12
-rw-r--r--dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r2.ebuild25
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-cpp/robin-hood-hashing/files/robin-hood-hashing-include-cstdint.patch b/dev-cpp/robin-hood-hashing/files/robin-hood-hashing-include-cstdint.patch
new file mode 100644
index 000000000000..e5f10b7a0126
--- /dev/null
+++ b/dev-cpp/robin-hood-hashing/files/robin-hood-hashing-include-cstdint.patch
@@ -0,0 +1,12 @@
+diff --git a/src/include/robin_hood.h b/src/include/robin_hood.h
+index b4e0fbc..b83eaef 100644
+--- a/src/include/robin_hood.h
++++ b/src/include/robin_hood.h
+@@ -39,6 +39,7 @@
+ #define ROBIN_HOOD_VERSION_PATCH 5 // for backwards-compatible bug fixes
+
+ #include <algorithm>
++#include <cstdint>
+ #include <cstdlib>
+ #include <cstring>
+ #include <functional>
diff --git a/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r2.ebuild b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r2.ebuild
new file mode 100644
index 000000000000..9e31bea3b72a
--- /dev/null
+++ b/dev-cpp/robin-hood-hashing/robin-hood-hashing-3.11.5-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+SRC_URI="https://github.com/martinus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Fast & memory efficient hashtable based on robin hood hashing for C++11/14/17/20"
+HOMEPAGE="https://github.com/martinus/robin-hood-hashing"
+
+LICENSE="MIT"
+SLOT="0"
+
+PATCHES=( "${FILESDIR}/${PN}-include-cstdint.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DRH_STANDALONE_PROJECT=OFF
+ -DCMAKE_INSTALL_LIBDIR="${EPREFIX}/usr/share/"
+ )
+ cmake_src_configure
+}