summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2024-06-17 02:18:59 -0400
committerSam James <sam@gentoo.org>2024-06-18 03:08:52 +0100
commitf58b8c8536d5e5f8453fcf7e04f2505b2a627a67 (patch)
tree7dd33f2e4c97c6eb45113fc879bf1fe9f687481f /dev-cpp
parentdev-cpp/gtest: enable py3.13 (diff)
downloadgentoo-f58b8c8536d5e5f8453fcf7e04f2505b2a627a67.tar.gz
gentoo-f58b8c8536d5e5f8453fcf7e04f2505b2a627a67.tar.bz2
gentoo-f58b8c8536d5e5f8453fcf7e04f2505b2a627a67.zip
dev-cpp/gtest: fix test failure with -O2/-O3 on arm hardfloat arch
Testing on arm hardfloat architecture with -O2/-O3 causes a unittest to fail. Do like Debian does and replace with -O1 until upstream addresses it. Closes: https://bugs.gentoo.org/925093 Suggested-by: Sam James <sam@gentoo.org> Signed-off-by: Peter Levine <plevine457@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gtest/gtest-1.14.0-r1.ebuild76
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild6
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-cpp/gtest/gtest-1.14.0-r1.ebuild b/dev-cpp/gtest/gtest-1.14.0-r1.ebuild
new file mode 100644
index 000000000000..aed50c96f6e4
--- /dev/null
+++ b/dev-cpp/gtest/gtest-1.14.0-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Python is required for tests and some build tasks.
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit cmake-multilib flag-o-matic python-any-r1 toolchain-funcs
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/google/googletest"
+else
+ if [[ -z ${GOOGLETEST_COMMIT} ]]; then
+ SRC_URI="https://github.com/google/googletest/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/googletest-${PV}
+ else
+ SRC_URI="https://github.com/google/googletest/archive/${GOOGLETEST_COMMIT}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}"/googletest-${GOOGLETEST_COMMIT}
+ fi
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+fi
+
+DESCRIPTION="Google C++ Testing Framework"
+HOMEPAGE="https://github.com/google/googletest"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+multilib_src_configure() {
+ if use arm && [[ $(tc-is-softfloat) =~ (softfp)|(no) ]]; then
+ replace-flags -O* -O1 # bug #925093
+ fi
+
+ local mycmakeargs=(
+ -DBUILD_GMOCK=ON
+ -DINSTALL_GTEST=ON
+
+ # tests
+ -Dgmock_build_tests=$(usex test)
+ -Dgtest_build_tests=$(usex test)
+ )
+ use test && mycmakeargs+=( -DPython3_EXECUTABLE="${PYTHON}" )
+
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ # Exclude tests that fail with FEATURES="usersandbox"
+ cmake_src_test -E "googletest-(death-test|port)-test"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ newdoc googletest/README.md README.googletest.md
+ newdoc googlemock/README.md README.googlemock.md
+
+ use doc && dodoc -r docs/.
+
+ if use examples; then
+ docinto examples
+ dodoc googletest/samples/*.{cc,h}
+ fi
+}
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index 175fed22f13f..aed50c96f6e4 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=8
# Python is required for tests and some build tasks.
PYTHON_COMPAT=( python3_{10..13} )
-inherit cmake-multilib python-any-r1
+inherit cmake-multilib flag-o-matic python-any-r1 toolchain-funcs
if [[ ${PV} == "9999" ]]; then
inherit git-r3
@@ -39,6 +39,10 @@ pkg_setup() {
}
multilib_src_configure() {
+ if use arm && [[ $(tc-is-softfloat) =~ (softfp)|(no) ]]; then
+ replace-flags -O* -O1 # bug #925093
+ fi
+
local mycmakeargs=(
-DBUILD_GMOCK=ON
-DINSTALL_GTEST=ON