summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2023-02-03 20:32:05 +0000
committerSam James <sam@gentoo.org>2023-02-15 05:52:17 +0000
commit4b0697e7f59dcda2a557c6dd66d6eca4e22e3793 (patch)
tree7cea5b84b87aade68fa749c1efe1e67eba809098 /dev-db/mydumper/mydumper-0.13.1.2.ebuild
parentapp-admin/syslog-ng: add 4.0.1 (diff)
downloadgentoo-4b0697e7f59dcda2a557c6dd66d6eca4e22e3793.tar.gz
gentoo-4b0697e7f59dcda2a557c6dd66d6eca4e22e3793.tar.bz2
gentoo-4b0697e7f59dcda2a557c6dd66d6eca4e22e3793.zip
dev-db/mydumper: add 0.13.1.2
Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/mydumper/mydumper-0.13.1.2.ebuild')
-rw-r--r--dev-db/mydumper/mydumper-0.13.1.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-db/mydumper/mydumper-0.13.1.2.ebuild b/dev-db/mydumper/mydumper-0.13.1.2.ebuild
new file mode 100644
index 000000000000..bcf83752cc30
--- /dev/null
+++ b/dev-db/mydumper/mydumper-0.13.1.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit cmake
+
+MY_PV="$(ver_rs 3 -)"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A high-performance multi-threaded backup (and restore) toolset for MySQL"
+HOMEPAGE="https://github.com/maxbube/mydumper"
+SRC_URI="https://github.com/maxbube/mydumper/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="app-arch/zstd
+ dev-db/mysql-connector-c:=
+ dev-libs/glib:2
+ dev-libs/libpcre
+ dev-libs/openssl:=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ doc? ( dev-python/sphinx )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.13.1-atomic.patch" #654314
+)
+
+src_prepare() {
+ # respect user cflags; do not expand ${CMAKE_C_FLAGS} (!)
+ sed -i -e 's|-O3 -g -Werror|${CMAKE_C_FLAGS}|' CMakeLists.txt || die
+
+ # fix doc install path
+ sed -i -e "s|share/doc/mydumper|share/doc/${PF}|" docs/CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(-DBUILD_DOCS=$(usex doc))
+
+ cmake_src_configure
+}