summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-01-23 15:11:28 -0500
committerSam James <sam@gentoo.org>2024-01-24 06:54:40 +0000
commit8d0bb288f480f0df7422a9d9b306709787350d83 (patch)
tree33770d7350d0eda244fe80ab6e4c259f9c9beb82 /dev-db/mysql
parentdev-util/cccc: migrate checking for enabled lto, to tc-is-lto (diff)
downloadgentoo-8d0bb288f480f0df7422a9d9b306709787350d83.tar.gz
gentoo-8d0bb288f480f0df7422a9d9b306709787350d83.tar.bz2
gentoo-8d0bb288f480f0df7422a9d9b306709787350d83.zip
dev-db/mysql: migrate checking for enabled lto, to tc-is-lto
This toolchain func was recently added, and vis a lot more reliable than get-flagq. mysql attempts to manually handle some edge case, for example if the active flags contain `-flto -fno-lto` then tc-is-lto gets it correct but with is-flagq we have to manually check both. On the other hand, mysql doesn't handle detecting -flto=8. Using tc-is-lto is the preferred way to handle this from now on. We would rather use this wherever possible. Drops a bit of pointless logging. We don't need an `einfo` to tell us that make.conf is being respected. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/mysql')
-rw-r--r--dev-db/mysql/mysql-8.0.27-r1.ebuild13
-rw-r--r--dev-db/mysql/mysql-8.0.31-r2.ebuild13
-rw-r--r--dev-db/mysql/mysql-8.0.32-r2.ebuild13
-rw-r--r--dev-db/mysql/mysql-8.0.34.ebuild9
4 files changed, 14 insertions, 34 deletions
diff --git a/dev-db/mysql/mysql-8.0.27-r1.ebuild b/dev-db/mysql/mysql-8.0.27-r1.ebuild
index 8a28bc5b2b53..fb831d0ded5e 100644
--- a/dev-db/mysql/mysql-8.0.27-r1.ebuild
+++ b/dev-db/mysql/mysql-8.0.27-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -238,15 +238,10 @@ src_configure() {
-DWITH_ROUTER=$(usex router ON OFF)
)
- if is-flagq -fno-lto ; then
- einfo "LTO disabled via {C,CXX,F,FC}FLAGS"
- mycmakeargs+=( -DWITH_LTO=OFF )
- elif is-flagq -flto ; then
- einfo "LTO forced via {C,CXX,F,FC}FLAGS"
- myconf+=( -DWITH_LTO=ON )
+ if tc-is-lto ; then
+ mycmakeargs+=( -DWITH_LTO=ON )
else
- # Disable automagic
- myconf+=( -DWITH_LTO=OFF )
+ mycmakeargs+=( -DWITH_LTO=OFF )
fi
if use test ; then
diff --git a/dev-db/mysql/mysql-8.0.31-r2.ebuild b/dev-db/mysql/mysql-8.0.31-r2.ebuild
index c93dec93051e..854e55432dfc 100644
--- a/dev-db/mysql/mysql-8.0.31-r2.ebuild
+++ b/dev-db/mysql/mysql-8.0.31-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -238,15 +238,10 @@ src_configure() {
-DWITH_ROUTER=$(usex router ON OFF)
)
- if is-flagq -fno-lto ; then
- einfo "LTO disabled via {C,CXX,F,FC}FLAGS"
- mycmakeargs+=( -DWITH_LTO=OFF )
- elif is-flagq -flto ; then
- einfo "LTO forced via {C,CXX,F,FC}FLAGS"
- myconf+=( -DWITH_LTO=ON )
+ if tc-is-lto ; then
+ mycmakeargs+=( -DWITH_LTO=ON )
else
- # Disable automagic
- myconf+=( -DWITH_LTO=OFF )
+ mycmakeargs+=( -DWITH_LTO=OFF )
fi
if use test ; then
diff --git a/dev-db/mysql/mysql-8.0.32-r2.ebuild b/dev-db/mysql/mysql-8.0.32-r2.ebuild
index c2f3cdba598b..4f6fa4715c82 100644
--- a/dev-db/mysql/mysql-8.0.32-r2.ebuild
+++ b/dev-db/mysql/mysql-8.0.32-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -246,15 +246,10 @@ src_configure() {
-DWITH_ROUTER=$(usex router ON OFF)
)
- if is-flagq -fno-lto ; then
- einfo "LTO disabled via {C,CXX,F,FC}FLAGS"
- mycmakeargs+=( -DWITH_LTO=OFF )
- elif is-flagq -flto ; then
- einfo "LTO forced via {C,CXX,F,FC}FLAGS"
- myconf+=( -DWITH_LTO=ON )
+ if tc-is-lto ; then
+ mycmakeargs+=( -DWITH_LTO=ON )
else
- # Disable automagic
- myconf+=( -DWITH_LTO=OFF )
+ mycmakeargs+=( -DWITH_LTO=OFF )
fi
if use test ; then
diff --git a/dev-db/mysql/mysql-8.0.34.ebuild b/dev-db/mysql/mysql-8.0.34.ebuild
index 074d23884b7c..2b86120d9b9a 100644
--- a/dev-db/mysql/mysql-8.0.34.ebuild
+++ b/dev-db/mysql/mysql-8.0.34.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -257,14 +257,9 @@ src_configure() {
)
fi
- if is-flagq -fno-lto ; then
- einfo "LTO disabled via {C,CXX,F,FC}FLAGS"
- mycmakeargs+=( -DWITH_LTO=OFF )
- elif is-flagq -flto ; then
- einfo "LTO forced via {C,CXX,F,FC}FLAGS"
+ if tc-is-lto ; then
mycmakeargs+=( -DWITH_LTO=ON )
else
- # Disable automagic
mycmakeargs+=( -DWITH_LTO=OFF )
fi