summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2018-10-22 14:21:17 +0200
committerMichael Haubenwallner <haubi@gentoo.org>2018-10-22 14:22:02 +0200
commite1a42dfb7912831eb273d0356822b3870f5fdb7a (patch)
treede653f04c8b415aab2b0249435a733217e1b548f /dev-db/oracle-instantclient/files
parentsys-kernel/gentoo-sources: Linux patch 4.19.0 and additional patches (diff)
downloadgentoo-e1a42dfb7912831eb273d0356822b3870f5fdb7a.tar.gz
gentoo-e1a42dfb7912831eb273d0356822b3870f5fdb7a.tar.bz2
gentoo-e1a42dfb7912831eb273d0356822b3870f5fdb7a.zip
dev-db/oracle-instantclient: fix precomp install
With credits to Stefan Gast in bug#597520, tweak paths in demo_proc_ic.mk and pcscfg.cfg, move the latter to /etc/oracle/, and do not install the Pro*COBOL precompiler, but Pro*C only. Also, use relative paths for symlinks. Closes https://bugs.gentoo.org/597520 Package-Manager: Portage-2.3.49, Repoman-2.3.10 Signed-off-by: Michael Haubenwallner <haubi@gentoo.org>
Diffstat (limited to 'dev-db/oracle-instantclient/files')
-rw-r--r--dev-db/oracle-instantclient/files/18.3.0.0-makefile.patch2
-rw-r--r--dev-db/oracle-instantclient/files/18.3.0.0-proc-makefile.patch27
2 files changed, 28 insertions, 1 deletions
diff --git a/dev-db/oracle-instantclient/files/18.3.0.0-makefile.patch b/dev-db/oracle-instantclient/files/18.3.0.0-makefile.patch
index eb6fc025d78b..bc4445fe354e 100644
--- a/dev-db/oracle-instantclient/files/18.3.0.0-makefile.patch
+++ b/dev-db/oracle-instantclient/files/18.3.0.0-makefile.patch
@@ -14,7 +14,7 @@ This provides absolute paths for headers and libraries.
+else
+LIBDIR=lib
+endif
-+ICINCHOME=$(ORACLE_HOME)/sdk/include
++ICINCHOME=$(ORACLE_HOME)/include
+ICLIBHOME=$(ORACLE_HOME)/$(LIBDIR)
ICLIBPATH=-L$(ICLIBHOME)
THREADLIBS=-lthread
diff --git a/dev-db/oracle-instantclient/files/18.3.0.0-proc-makefile.patch b/dev-db/oracle-instantclient/files/18.3.0.0-proc-makefile.patch
new file mode 100644
index 000000000000..a197c2c7236f
--- /dev/null
+++ b/dev-db/oracle-instantclient/files/18.3.0.0-proc-makefile.patch
@@ -0,0 +1,27 @@
+--- instantclient_18_3/sdk/demo/demo_proc_ic.mk.orig 2018-10-22 13:34:44.302293002 +0200
++++ instantclient_18_3/sdk/demo/demo_proc_ic.mk 2018-10-22 13:38:55.015321571 +0200
+@@ -37,8 +37,13 @@
+ cc=/usr/bin/gcc
+
+ # InstantClient Directories.
+-ICSDKHOME=../
+-ICLIBHOME=../../
++ifeq ($(BUILD32),T)
++LIBDIR=lib32
++else
++LIBDIR=lib
++endif
++ICSDKHOME=$(ORACLE_HOME)/
++ICLIBHOME=$(ORACLE_HOME)/$(LIBDIR)
+
+ MKLINK=ln
+ REMOVE=rm -rf
+@@ -48,7 +53,7 @@
+ MAKEFILE=demo_proc_ic.mk
+ PROCDEMO=procdemo
+
+-PROC=$(ICSDKHOME)proc
++PROC=$(ICSDKHOME)bin/proc
+ SO_EXT=.so
+ I_SYM=-I
+