summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-db/pgpool2/pgpool2-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-db/pgpool2/pgpool2-9999.ebuild')
-rw-r--r--dev-db/pgpool2/pgpool2-9999.ebuild117
1 files changed, 117 insertions, 0 deletions
diff --git a/dev-db/pgpool2/pgpool2-9999.ebuild b/dev-db/pgpool2/pgpool2-9999.ebuild
new file mode 100644
index 000000000000..4c518f713e6c
--- /dev/null
+++ b/dev-db/pgpool2/pgpool2-9999.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+[[ ${PV} == 9999 ]] && MY_P=${PN/2/-II} || MY_P="${PN/2/-II}-${PV}"
+
+ECVS_SERVER="cvs.pgfoundry.org:/cvsroot/pgpool"
+ECVS_MODULE="pgpool-II"
+[[ ${PV} == 9999 ]] && SCM_ECLASS="cvs"
+inherit base user ${SCM_ECLASS}
+unset SCM_ECLASS
+
+DESCRIPTION="Connection pool server for PostgreSQL"
+HOMEPAGE="http://www.pgpool.net/"
+[[ ${PV} == 9999 ]] || SRC_URI="http://www.pgpool.net/download.php?f=${MY_P}.tar.gz -> ${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+
+# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+
+IUSE="memcached pam ssl static-libs"
+
+RDEPEND="
+ dev-db/postgresql
+ memcached? ( dev-libs/libmemcached )
+ pam? ( sys-auth/pambase )
+ ssl? ( dev-libs/openssl )
+"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ !!dev-db/pgpool
+"
+
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ enewgroup postgres 70
+ enewuser pgpool -1 -1 -1 postgres
+
+ # We need the postgres user as well so we can set the proper
+ # permissions on the sockets without getting into fights with
+ # PostgreSQL's initialization scripts.
+ enewuser postgres 70 /bin/bash /var/lib/postgresql postgres
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/pgpool_run_paths.patch"
+
+ local pg_config_manual="$(pg_config --includedir)/pg_config_manual.h"
+ local pgsql_socket_dir=$(grep DEFAULT_PGSOCKET_DIR "${pg_config_manual}" | \
+ sed 's|.*\"\(.*\)\"|\1|g')
+ local pgpool_socket_dir="$(dirname $pgsql_socket_dir)/pgpool"
+
+ sed "s|@PGSQL_SOCKETDIR@|${pgsql_socket_dir}|g" \
+ -i *.conf.sample* pool.h || die
+
+ sed "s|@PGPOOL_SOCKETDIR@|${pgpool_socket_dir}|g" \
+ -i *.conf.sample* pool.h || die
+}
+
+src_configure() {
+ local myconf
+ use memcached && \
+ myconf="--with-memcached=\"${EROOT%/}/usr/include/libmemcached\""
+ use pam && myconf+=' --with-pam'
+
+ econf \
+ --disable-rpath \
+ --sysconfdir="${EROOT%/}/etc/${PN}" \
+ $(use_with ssl openssl) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_compile() {
+ emake
+
+ cd sql
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ cd sql
+ emake DESTDIR="${D}" install
+ cd "${S}"
+
+ # `contrib' moved to `extension' with PostgreSQL 9.1
+ local pgslot=$(postgresql-config show)
+ if [[ ${pgslot//.} > 90 ]] ; then
+ cd "${ED%/}$(pg_config --sharedir)"
+ mv contrib extension || die
+ cd "${S}"
+ fi
+
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+
+ # Documentation
+ dodoc NEWS TODO doc/where_to_send_queries.{pdf,odg}
+ dohtml -r doc
+
+ # Examples and extras
+ insinto "/usr/share/${PN}"
+ doins doc/{pgpool_remote_start,basebackup.sh,recovery.conf.sample}
+ mv "${ED%/}/usr/share/${PN/2/-II}" "${ED%/}/usr/share/${PN}" || die
+
+ # One more thing: Evil la files!
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}