summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-12-08 23:14:01 +0100
committerSam James <sam@gentoo.org>2022-12-15 04:44:00 +0000
commit95a8c3eafa0cc5d180275addd2ecfeeaeef496a3 (patch)
tree3acd2c1d847926fcef433f0ff79c9e83b5563484 /dev-db/sqlmap
parentdev-util/ROPgadget: add 7.2 (diff)
downloadgentoo-95a8c3eafa0cc5d180275addd2ecfeeaeef496a3.tar.gz
gentoo-95a8c3eafa0cc5d180275addd2ecfeeaeef496a3.tar.bz2
gentoo-95a8c3eafa0cc5d180275addd2ecfeeaeef496a3.zip
dev-db/sqlmap: add 1.6.12
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/28607 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-db/sqlmap')
-rw-r--r--dev-db/sqlmap/Manifest1
-rw-r--r--dev-db/sqlmap/sqlmap-1.6.12.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-db/sqlmap/Manifest b/dev-db/sqlmap/Manifest
index 705f72a03313..29f0b9b0de9b 100644
--- a/dev-db/sqlmap/Manifest
+++ b/dev-db/sqlmap/Manifest
@@ -1,2 +1,3 @@
DIST sqlmap-1.6.10.gh.tar.gz 7206382 BLAKE2B 2beaf7d49599f7e8072d0725bc58d00c4fd1096316080013f0892cd1c25a2b05c5682191bc87aa9210b21393142aafb43c8ecb5855699716f287e01be2b6ffff SHA512 a2d08f62a4e78fee6761a17b45913dc8794ec07ae466042f41bb5ba524221d670ae6c8f0cde92590d45f0919cb52c1fb98b83e58099eba1b0fd8e833d68d12ad
DIST sqlmap-1.6.11.gh.tar.gz 7206836 BLAKE2B fd55093c873537d8607822d4bf84b6eed47a1a01e89750265c040f70a82faea2141096a611f66c46f025cfe2893cb0401e63034c80be6d736cc25246cd70e3fd SHA512 d773ab5e45e933ed64533e3ede0ec3e25543ecf9489fa72dc57558385ddb7c515e57952022b8c350fbeb347f6e935864e22c2cc51abee81740fd66478349e2ab
+DIST sqlmap-1.6.12.gh.tar.gz 7207020 BLAKE2B 9d26c5a5dce4bd2eb5ab38b307d211fefc27a2fe0784f7d91dade2a1eecabdbeec506eeb8bed4a85993873760bb050a77c16d08f01ecdaad1e82e56dbf17c12e SHA512 297cd31f055ee7ee41244f205e9cf71209a29d71e7002331a0d7eba04a151a238cef5c3c06710af516b86cdb95ae9bb72b63019830004a366008b798aad768aa
diff --git a/dev-db/sqlmap/sqlmap-1.6.12.ebuild b/dev-db/sqlmap/sqlmap-1.6.12.ebuild
new file mode 100644
index 000000000000..6b74d8864800
--- /dev/null
+++ b/dev-db/sqlmap/sqlmap-1.6.12.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit bash-completion-r1 python-single-r1 wrapper
+
+DESCRIPTION="An automatic SQL injection and database takeover tool"
+HOMEPAGE="https://sqlmap.org/"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/sqlmapproject/sqlmap"
+else
+ SRC_URI="https://github.com/sqlmapproject/sqlmap/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# sqlmap (GPL-2+)
+# ansitrm (BSD)
+# beautifulsoup (BSD)
+# bottle (MIT)
+# chardet (LGPL-2.1+)
+# clientform (BSD)
+# colorama (BSD)
+# fcrypt (BSD-2)
+# identitywaf (MIT)
+# keepalive (LGPL-2.1+)
+# magic (MIT)
+# multipartpost (LGPL-2.1+)
+# ordereddict (MIT)
+# prettyprint (BSD-2)
+# pydes (public-domain)
+# six (MIT)
+# socks (BSD)
+# termcolor (BSD)
+# wininetpton (public-domain)
+LICENSE="BSD BSD-2 GPL-2+ LGPL-2.1+ MIT public-domain"
+SLOT="0"
+
+RDEPEND="${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DOCS=( doc/ README.md )
+
+src_install () {
+ einstalldocs
+
+ insinto /usr/share/${PN}/
+ doins -r *
+ python_optimize "${ED}"/usr/share/${PN}
+
+ make_wrapper ${PN} \
+ "${EPYTHON} ${EPREFIX}/usr/share/${PN}/sqlmap.py"
+
+ newbashcomp "${FILESDIR}"/sqlmap.bash-completion sqlmap
+}