summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2020-06-01 08:20:17 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2020-06-01 08:20:24 -0400
commitdd16b275d4a6f22bd1d09555092c980f126655e4 (patch)
treeaa2999ca9ab4c310d7662b58818f437bdb92ef2c /dev-db
parentprofiles: Last rite app-dicts/stardict-quick-eng-fra (diff)
downloadgentoo-dd16b275d4a6f22bd1d09555092c980f126655e4.tar.gz
gentoo-dd16b275d4a6f22bd1d09555092c980f126655e4.tar.bz2
gentoo-dd16b275d4a6f22bd1d09555092c980f126655e4.zip
dev-db/pgxnclient: Bump to 1.3
Compatible with Python 3.6+ (allegedly). Bump EAPI to 7. Tests now using pytest, but the test data isn't yet included. So, tests fail. Bug: https://bugs.gentoo.org/718270 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgxnclient/Manifest1
-rw-r--r--dev-db/pgxnclient/pgxnclient-1.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-db/pgxnclient/Manifest b/dev-db/pgxnclient/Manifest
index 571fa88c11f5..8cb8e0806208 100644
--- a/dev-db/pgxnclient/Manifest
+++ b/dev-db/pgxnclient/Manifest
@@ -1,2 +1,3 @@
DIST pgxnclient-1.2.1.tar.gz 87275 BLAKE2B 794ee6201988ba523cdcb4ee5a6287625cb3dd8a30ad750266d7adb739792b7f8e852d5d01f746fb6b05b54c98d677854dceacc57e41b05efba094efabc6a129 SHA512 3fa864b1ebb5dedaf75515b5efe4c453f02acff558f7b82d2648da62e58c93e050049a7688171a69593784d9963bb62f4ad3674d526284554dbeb4f4a4ea1dbf
DIST pgxnclient-1.2.tar.gz 86436 BLAKE2B 796191d31000ff75360e0990bb20ca88af0fb1b908aac9ca7a6b7309b5420c56d045a67c775e8d5dda166f37ad956314f65bd2032c114cac7414bef9ad1a0d8e SHA512 d677f8d5346caf4de5d7e0d4e4031b8bdd932e343af7fc33e8895ebe51b1e9e6a11d7300d9e98ddc10242854f7d39c0a4196f41938e42f0b0e5158454e386deb
+DIST pgxnclient-1.3.tar.gz 51976 BLAKE2B 84ae5573588e6da0b01d5b05e296adc09f28a0b21ff81e5f2f14f3035a98ad5eb834d6793acf0a48a8b19190b989562e75094341f7c01b371028a0dd6a87b0f4 SHA512 fd9326107334d473db3466f776021186a5add389a93266b000c143131a0214b9773dd4cdd4688575cd720c8357afce1473838dea4aa5ff2564dcbc2c359de2dd
diff --git a/dev-db/pgxnclient/pgxnclient-1.3.ebuild b/dev-db/pgxnclient/pgxnclient-1.3.ebuild
new file mode 100644
index 000000000000..586f7287262e
--- /dev/null
+++ b/dev-db/pgxnclient/pgxnclient-1.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="PostgreSQL Extension Network Client"
+HOMEPAGE="http://pgxnclient.projects.postgresql.org/ https://pypi.org/project/pgxnclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+LICENSE="BSD"
+SLOT="0"
+
+IUSE="test"
+
+# Test data isn't included in releases. So, the tests fail.
+# https://github.com/pgxn/pgxnclient/issues/36
+RESTRICT="test
+ !test? ( test )"
+
+distutils_enable_tests pytest
+
+RDEPEND="dev-db/postgresql:*[server]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND+="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+src_prepare() {
+ sed "s/find_packages()/find_packages(exclude=['tests'])/" -i setup.py || die
+
+ default
+}