summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2024-10-14 14:38:44 +0200
committerSam James <sam@gentoo.org>2024-11-01 17:28:19 +0000
commit7ac25cfd23ae4799111cde50f2cef9a072425fe9 (patch)
treec8d9680c44a7bae3193eabbd3ff30cbb7bb8bfe4 /dev-debug
parentwww-servers/moonbridge: bump EAPI, fix variable order (diff)
downloadgentoo-7ac25cfd23ae4799111cde50f2cef9a072425fe9.tar.gz
gentoo-7ac25cfd23ae4799111cde50f2cef9a072425fe9.tar.bz2
gentoo-7ac25cfd23ae4799111cde50f2cef9a072425fe9.zip
dev-debug/scap-driver: add 0.18.1
Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-debug')
-rw-r--r--dev-debug/scap-driver/Manifest1
-rw-r--r--dev-debug/scap-driver/scap-driver-0.18.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-debug/scap-driver/Manifest b/dev-debug/scap-driver/Manifest
index a16f0e257e40..e2f920a0eef0 100644
--- a/dev-debug/scap-driver/Manifest
+++ b/dev-debug/scap-driver/Manifest
@@ -1,2 +1,3 @@
DIST falcosecurity-libs-0.17.2.tar.gz 4424458 BLAKE2B cbe3a689d3d93a6896b94fd54b35665b11263c07690a36d40617651f97806b0177af657824f62259df95a984d598a34c17ff942c73e3abd774569607dc22380f SHA512 8bb449d91c12225c08d678ea9a8e97a5b5e8828788b56d5b83ec3b3c6ad5e25d4f56120dba523ac9c593d02ee155026e2d4d47587be6f73f373f06fe7ddc2a0c
DIST falcosecurity-libs-0.17.3.tar.gz 4425090 BLAKE2B 3d6300bba2303715581d9b35f63e453f85a3889fa93233d3b1ca69f6ba92b33e0a7d90bbd160b765487b44771a1d94f5a1fb380cf4e5130506a885471dddb7e7 SHA512 05707c404bdd45c2e944b903dbbc1e5e0e5991a3d4cbe9ea357efb35b5ad0c4ede7cdd7b056a7dde2543cc2c0b8d5d3b42606202128b7287a80a1da686de169e
+DIST falcosecurity-libs-0.18.1.tar.gz 4473396 BLAKE2B 9e875430032adfc79db086e92e6bb356a9c87a529da27a613f49b18e7e32ebeb28e1859bdba8b35c826e9a0d9c77454d4b804e35d5bf13c2f077fed915355045 SHA512 eb9e4d770888d70cbcc9468a4044f50bbb16729f545660c9f1aa91da862410ee7cfa2702dba7eef161bf3a3e0b9090b64dd8e1694fdb83c55a6d2418d281042a
diff --git a/dev-debug/scap-driver/scap-driver-0.18.1.ebuild b/dev-debug/scap-driver/scap-driver-0.18.1.ebuild
new file mode 100644
index 000000000000..a867a67ec476
--- /dev/null
+++ b/dev-debug/scap-driver/scap-driver-0.18.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake linux-mod-r1
+
+DESCRIPTION="Kernel module for dev-debug/sysdig"
+HOMEPAGE="https://sysdig.com/"
+SRC_URI="https://github.com/falcosecurity/libs/archive/${PV}.tar.gz -> falcosecurity-libs-${PV}.tar.gz"
+S="${WORKDIR}/libs-${PV}"
+
+LICENSE="Apache-2.0 GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="!<dev-debug/sysdig-${PV}[modules]"
+
+CONFIG_CHECK="HAVE_SYSCALL_TRACEPOINTS ~TRACEPOINTS"
+
+# We need to specify the driver version manually since we do not use a git tree.
+# This version can be found as git tag on the same commit as the libs version.
+DRIVER_VERSION="7.3.0+driver"
+
+src_configure() {
+ local mycmakeargs=(
+ # we will use linux-mod, so just pretend to use bundled deps
+ # in order to make it through the cmake setup.
+ -DUSE_BUNDLED_DEPS=ON
+ -DCREATE_TEST_TARGETS=OFF
+ -DDRIVER_VERSION="${DRIVER_VERSION}"
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ local modlist=( scap=:"${BUILD_DIR}"/driver/src )
+ local modargs=( KERNELDIR="${KV_OUT_DIR}" )
+
+ linux-mod-r1_src_compile
+}