summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:05:50 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:10 +0100
commit0d855442ce991c07da60a9208ec13f7f4386473f (patch)
tree554a5e601b9cdc0f4494cb100db7ecac59919391 /dev-haskell/aeson-pretty
parentdev-haskell/attoparsec-aeson: new package, add 2.1.0.0 (diff)
downloadgentoo-0d855442ce991c07da60a9208ec13f7f4386473f.tar.gz
gentoo-0d855442ce991c07da60a9208ec13f7f4386473f.tar.bz2
gentoo-0d855442ce991c07da60a9208ec13f7f4386473f.zip
dev-haskell/aeson-pretty: add 0.8.10
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/aeson-pretty')
-rw-r--r--dev-haskell/aeson-pretty/Manifest1
-rw-r--r--dev-haskell/aeson-pretty/aeson-pretty-0.8.10.ebuild44
-rw-r--r--dev-haskell/aeson-pretty/metadata.xml18
3 files changed, 47 insertions, 16 deletions
diff --git a/dev-haskell/aeson-pretty/Manifest b/dev-haskell/aeson-pretty/Manifest
index a279351c9f2c..3ff96125c846 100644
--- a/dev-haskell/aeson-pretty/Manifest
+++ b/dev-haskell/aeson-pretty/Manifest
@@ -1,2 +1,3 @@
+DIST aeson-pretty-0.8.10.tar.gz 5894 BLAKE2B 11f743ec9eaf301412efdde98b7237b0445a1089532804271613fb189e9b58ceab9cf2f710ff6a9e40f9755413fb110df63f2a80449469d3d655eb684338f76b SHA512 9eb39f5d70fe841d10c4e9fcacc3b380aa2a377590e8165f11c11318f7cdacb26757713efbb2b8324b57d1d5d89a1b210094ac6ab385a4dd32a9f6591847c4ac
DIST aeson-pretty-0.8.9.cabal 2549 BLAKE2B 8039fb1ab628e04e0661331860ee2340c1dde9ed971619bdceb8b31500037fa94977034e07a9b8722b7bba818bda0b9b23cc608b71084121c276bce9a7e805da SHA512 b602bd81625dfd00906dd61613c2f4446f88c3afb82a0dec960de62802f5db17d2d77895f22108660f500831d9b0f24f5709b45b0f17f98630442842954dd5b7
DIST aeson-pretty-0.8.9.tar.gz 5802 BLAKE2B 85d13676bb6f569a9df0f88a0882f493a6a2e55a74e702fa14f1d419b337f2a9f9d531de3dbd5283c80237e6fac11babf5aaba8f29aaf272ce6fc062412f1878 SHA512 00c99799cbe9e268109116f909ea0d9ef2708e578ec363ba5455b43d76d1f89bc9820dcbd3a63a1fb300460d97a71105f028f4ad9853b56ce16a097826b1d3d5
diff --git a/dev-haskell/aeson-pretty/aeson-pretty-0.8.10.ebuild b/dev-haskell/aeson-pretty/aeson-pretty-0.8.10.ebuild
new file mode 100644
index 000000000000..4e095248d035
--- /dev/null
+++ b/dev-haskell/aeson-pretty/aeson-pretty-0.8.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="JSON pretty-printing library and command-line tool"
+HOMEPAGE="https://github.com/informatikr/aeson-pretty"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="+executable"
+
+RDEPEND=">=dev-haskell/base-compat-0.9:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.2.14.0:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-lang/ghc-8.8.1:=
+ >=dev-haskell/aeson-1.1:=[profile?] <dev-haskell/aeson-2.3:=[profile?]
+ executable? ( >=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/attoparsec-0.10:=[profile?]
+ dev-haskell/attoparsec-aeson:=[profile?]
+ >=dev-haskell/cmdargs-0.7:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+"
+
+src_configure() {
+ if use executable; then
+ local lib_flag=-lib-only
+ else
+ local lib_flag=lib-only
+ fi
+
+ haskell-cabal_src_configure \
+ --flag="${lib_flag}"
+}
diff --git a/dev-haskell/aeson-pretty/metadata.xml b/dev-haskell/aeson-pretty/metadata.xml
index da44aa251acf..260b34f47acb 100644
--- a/dev-haskell/aeson-pretty/metadata.xml
+++ b/dev-haskell/aeson-pretty/metadata.xml
@@ -6,25 +6,11 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
+ <flag name="executable">build/install the command-line tool as well as the library</flag>
<flag name="lib-only">don't build 'aeson-pretty' executable.</flag>
</use>
- <longdescription>
- A JSON pretty-printing library compatible with aeson as well as
- a command-line tool to improve readabilty of streams of JSON data.
-
- The /library/ provides the function "encodePretty". It is a drop-in
- replacement for aeson's "encode" function, producing JSON-ByteStrings for
- human readers.
-
- The /command-line tool/ reads JSON from stdin and writes prettified JSON
- to stdout. It also offers a complementary "compact"-mode, essentially the
- opposite of pretty-printing. If you specify @-flib-only@ like this
-
- &gt; cabal install -flib-only aeson-pretty
-
- the command-line tool will NOT be installed.
- </longdescription>
<upstream>
+ <remote-id type="hackage">aeson-pretty</remote-id>
<remote-id type="github">informatikr/aeson-pretty</remote-id>
</upstream>
</pkgmetadata>