summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:07:51 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:41 +0100
commitfb647252cdeed0c36e66fb82b78468a0529de820 (patch)
treee3ff10074cc10ff2d22e3cf1e9be2f4a669e4cdb /dev-haskell/hscolour
parentdev-haskell/hourglass: add 0.2.12-r1 (diff)
downloadgentoo-fb647252cdeed0c36e66fb82b78468a0529de820.tar.gz
gentoo-fb647252cdeed0c36e66fb82b78468a0529de820.tar.bz2
gentoo-fb647252cdeed0c36e66fb82b78468a0529de820.zip
dev-haskell/hscolour: add 1.25
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/hscolour')
-rw-r--r--dev-haskell/hscolour/Manifest1
-rw-r--r--dev-haskell/hscolour/hscolour-1.25.ebuild37
-rw-r--r--dev-haskell/hscolour/metadata.xml14
3 files changed, 41 insertions, 11 deletions
diff --git a/dev-haskell/hscolour/Manifest b/dev-haskell/hscolour/Manifest
index 1bc3dc7944b6..756c65f19d51 100644
--- a/dev-haskell/hscolour/Manifest
+++ b/dev-haskell/hscolour/Manifest
@@ -1 +1,2 @@
DIST hscolour-1.24.4.tar.gz 28729 BLAKE2B fdda7f784e35ff165981de53df5535b3294f5dbd5d1f484bcd34a20bfde014ddc9a916f20fae639420eca8cd4577f683d0e799459e846aabcc7cb4290b7035d2 SHA512 39b631c0a8346beff1c2e02ca8e72c1b1e3f7dafcedad7dc9de274e6750501de2bc553fe72a7d3459d4f9797e916f27e28ff96f705c2c0f9d3e0eec0ac6182c7
+DIST hscolour-1.25.tar.gz 28695 BLAKE2B c413533a6adac73a94d837aac9d1294e339e138a972e31bc3feb47b1ef3c1f96d7d09a46f72e336a112c91986b6a783c59f9066ec8454355780a52615f77f338 SHA512 00a9b679ae0fa13f3ad873991a1d1af953fb84cc2127387a014eaa8697265dc672c3c286b24a75e07c47b6c96a829aede6ef0e0d5f5939117821654319dc6c6c
diff --git a/dev-haskell/hscolour/hscolour-1.25.ebuild b/dev-haskell/hscolour/hscolour-1.25.ebuild
new file mode 100644
index 000000000000..7ab96d0275bd
--- /dev/null
+++ b/dev-haskell/hscolour/hscolour-1.25.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle"
+# avoid Cabal dependency as it's a dependency of most packages
+# including cabal depends.
+CABAL_FEATURES+=" nocabaldep"
+inherit haskell-cabal
+
+DESCRIPTION="Colourise Haskell code"
+HOMEPAGE="https://code.haskell.org/~malcolm/hscolour/"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+"
+
+src_configure() {
+ # llvm-general-pure passes rtsopts
+ haskell-cabal_src_configure --ghc-options=-rtsopts
+}
+
+src_install() {
+ cabal_src_install
+ if use doc; then
+ docinto html
+ dodoc hscolour.css
+ fi
+}
diff --git a/dev-haskell/hscolour/metadata.xml b/dev-haskell/hscolour/metadata.xml
index 9aae77a1da19..1194f4d00e90 100644
--- a/dev-haskell/hscolour/metadata.xml
+++ b/dev-haskell/hscolour/metadata.xml
@@ -5,15 +5,7 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- hscolour is a small Haskell script to colourise Haskell code. It currently
- has six output formats:
- ANSI terminal codes (optionally XTerm-256colour codes),
- HTML 3.2 with &lt;font&gt; tags,
- HTML 4.01 with CSS,
- HTML 4.01 with CSS and mouseover annotations,
- XHTML 1.0 with inline CSS styling,
- LaTeX,
- and mIRC chat codes.
- </longdescription>
+ <upstream>
+ <remote-id type="hackage">hscolour</remote-id>
+ </upstream>
</pkgmetadata>