summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-08-07 12:13:49 +1000
committerSam James <sam@gentoo.org>2022-08-10 04:34:46 +0100
commit94604301db6ebc133e0ee2062b66fe0df93c2f0e (patch)
treefd53152b28a6a5bc1d09bd42345e78f4b025705f /dev-haskell/streaming-commons
parentdev-haskell/tls: drop 1.5.4 (diff)
downloadgentoo-94604301db6ebc133e0ee2062b66fe0df93c2f0e.tar.gz
gentoo-94604301db6ebc133e0ee2062b66fe0df93c2f0e.tar.bz2
gentoo-94604301db6ebc133e0ee2062b66fe0df93c2f0e.zip
dev-haskell/streaming-commons: add 0.2.2.4
Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/streaming-commons')
-rw-r--r--dev-haskell/streaming-commons/Manifest1
-rw-r--r--dev-haskell/streaming-commons/streaming-commons-0.2.2.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-haskell/streaming-commons/Manifest b/dev-haskell/streaming-commons/Manifest
index fb12aa5b57c0..4c03efa025e1 100644
--- a/dev-haskell/streaming-commons/Manifest
+++ b/dev-haskell/streaming-commons/Manifest
@@ -1 +1,2 @@
DIST streaming-commons-0.2.1.2.tar.gz 86776 BLAKE2B 01f4a88fb87055bb315278e0391880025b38765faa27e788d3b184c4942af0b8c26e147639e4413a029ae30e03991d083adf49aac89759b2fe2c058e945acd70 SHA512 7b6f39237f9ac13ca2d8205a43fee17c6edfe6609a1119903f8648aed151ef92779af7a8dfdfb108dea679cd26c83dfb5d21285d51f91dec0ad10debd100b8e7
+DIST streaming-commons-0.2.2.4.tar.gz 84330 BLAKE2B 08b729471b3fdc9c5508ffca0e9ce52f38a33b25855f027ae5924e28387e80b369e8c41a33fae49bbb6d5845985954377c2067d56b26995336faa51cb792f83d SHA512 e552bba766e5b816cbd448d1cec86c5c7593f3f13c6da42c74ebf2c9698be3a3174dd922cf70de1b4940b53e580f396a51cebff6b62db305fb0fb48a5c7658bb
diff --git a/dev-haskell/streaming-commons/streaming-commons-0.2.2.4.ebuild b/dev-haskell/streaming-commons/streaming-commons-0.2.2.4.ebuild
new file mode 100644
index 000000000000..50f3584f0943
--- /dev/null
+++ b/dev-haskell/streaming-commons/streaming-commons-0.2.2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Common lower-level functions needed by various streaming data libraries"
+HOMEPAGE="https://github.com/fpco/streaming-commons"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RESTRICT=test # requires network
+
+RDEPEND="dev-haskell/async:=[profile?]
+ >=dev-haskell/network-2.4.0.0:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/stm:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-8.6.3:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4.0.1
+ test? ( >=dev-haskell/hspec-1.8
+ dev-haskell/quickcheck )
+"